Macbook Pro not recognizing WD external drive after disconnects without ejecting

bvon

Registered
I've got a Mid 2015 MacBook Pro running Monterey.
A WD 1TB My Passport quit being recognized by the system after several times of inadvertently being unplugged without ejecting. It's got a micro usb connection that would fall out a lot. The drive lights up and whirrs when connected and the light stays solid but I can't see the drive. Here's what I've tried.

Tried a different USB cable
Tried different USB port
Tried it on another computer w/ same result
Enabled see external disks
Looked for it in Disk Utility but it doesn't show up.
Looked for it with Terminal list command but it doesn't show up
Rebooted
Upgraded to Monterey
Tried WD Utilities
Removed it from external casing to plug in more directly but still is via usb micro interface. Not sure how to put it into another enclosure or interface.
Tried to manually force quit the fsck process from activity monitor but there is no fsck process running.
Downloaded a couple of different recovery programs Recoverit and Easus and it's not recognized.
It did show up with Easeus twice but when I tried to search the disk it spontaneously dropped/disconnected after 2 - 3 minutes.

Of course the files on their are not backed up. I was working my way towards that over the next few days. Anyway I'd like to get at them. I know data recovery would seem to be my next step but I thought I'd reach out to see if anyone had any other suggestions/recommendations. It seems the issue is from the frequent disconnecting without ejecting but I'm not sure what else to try.
 

Satcomer

In Geostationary Orbit
Yes that's is how it's suppose to work on a BSD system! So a DAS has to be mounted and unmounted on a Mac! You do this by several methods like digging the das to the Trash Can in Dock and the other is highlighting the DAS and then use your other hand to press the key combination: comma button+e for ejecting the drive so you can safely disconnect it!

So do one simple thing is don't yet reconnect it, restart your Mac and get back into it and mount your drive!
 
Top