MacOS 9.1 not recognised for Classic


I installed OSX and a fresh OS 9.1 on the same partition. When choosing a 9.1 system for Classic in OSX preferences, the OS 9.1 thats on the same partition as OSX is not available, yet an OS 9.1 on a different partition is available. Any ideas on a possible fix?


I had the same problem, but this fixed it:

Go into startup disk and wait until it's done checking all the disks

Go back into classic, and (it worked for me...) the disk should be selectable


OS X ran beautifully for me for 3 days.

Until this morning.

I started up to an old friend: the blinking question mark.
Could not boot into OS X, so I booted into OS 9.1. Ran Disk First Aid, it repaired a couple of minor errors, and I tried rebooting into OS X.

This time, it worked. I'm back in OS X. Every time I try to run Classic, however, I get the following message:

"System file of the selected startup disk is prior to version 9.1 and is not supported by Classic. Please select a different startup disk using the Classic preferences panel and restart Classic."

Thing is, the Classic preferences panel won't let me choose a different startup disk, since it does not recognize the 9.1 system folder on my HD.

So, I put a call into Apple Support. Two hours, and two clean installs of 9.1, later, and OS X still won't recognize 9.1 (even tried a clean reinstall of OS X and OS 9.1 again, to no avail.) Their final words to me? Reformat.

The advice above, however, solved the problem. Thanks a million! All I did was go into the Startup Disk preferences panel, and waited for it to locate 9.1, then I went back to Classic, and it started right up. Called Apple support to tell them the soulution, since they were as baffled as I was.

Maybe that's why they tell you to partition...