MacOS X on Beige


I'm trying to install a very ;-) late version of X.
My hardware looks like this:
PM G3 beige 266 MHz, overclocked to 300MHz (jumperstylee).
320 Mb RAM, 6 Mb VRAM.
1 Original Apple IDE 4 Gb, bus 1, ID 1(slave) OS 9.1
1 Original Apple IDE 4 Gb, bus 0, ID 0(master)

My problem looks like this:
When I'm trying to install X (from CD mounted in OS 9 or booted directly (C on startup), the happy Mac appears, 1 minute later I get a split folder icon.The fun is over :(

Any tips ?
sorry no tips for ya, but I have another problem! :)

Here goes:

Installation starts fine, booting of the cd and all.  I click through all of the screens fine until I come to the Select Destination screen.  All of my disks are greyed out!  I can't select any of my disks for installation.  So, I restart the installer and go to disk setup.  Everything works fine here and I can partition my disk.  I continue with the install and still no luck.  Any beige owners out there experienced this?  Could this be some incapatibility with some of my hardware?  Here's my system:

36.5 GB Maxtor HD w/2 HFS+ partitions of equal size
128 MB RAM
Voodoo3 installed but not running a monitor
3rd party USB 4-port PCI card
Asante 100 mbit Ethernet PCI card
MacOS 9.1 installed on the second partition

Any ideas?

(Posted at also)
On a beige, MacOS X can't install on bigger partititions than 8 Gb. Try to make smallar volumes.

j00s (still can't install X --> beige :-( )
Originally posted by j00s
On a beige, MacOS X can't install on bigger partititions than 8 Gb. Try to make smallar volumes.

And it must be the first <8Gb of the disk.

that sucks, I installed the Public Beta and Build 4k17 this way and they worked fine. So they TOOK OUT support for installing on >8 GB partitions?

Sorry, I missunderstood a rumour :(
This is from the final X-CD...the before you install PDF.

"If you install Mac OS X on a PowerBook G3 Series
computer that does not have USB,an original
Power Macintosh G3 (Beige),or a Rev.A,Rev.B,
Rev.C,or Rev.D iMac,and the hard disk is larger
than 8 GB with more than one partition,be sure
to select a destination partition for Mac OS X
that is completely within the first 8 GB of the disk."
Ah, ok I'll try that later. My first partition is 17GB so obviously it isn't in the first 8 GB of the disk. Thanks. Heh, I'm at work now on a Dual 450 and I have to go home to my G3/266. Argh!
Maybe I am dumb but I do not read that to mean that you have to install on some thing 8GB or smaller but rather that if it is partitioned and larger you have to install onto the first 8GB.

I haven't tried to put it on my Beige G3 [with a 30GB and a 20GB] yet.
Seems fairly clear to me....."completely within the first 8 GB of the disk" means you must install into a partition with a max. of 8gb and it must be all within the first 8gb of that hard disk.

Try it. If your problem is solved then that's your answer.

You may also want to double check that your master/slave jumper settings are all correct too.
I have had similar problems. Had the PB on and running with 8.6 on a separate drive. Got the package Saturday. Immediately upgraded to 9.1. Not a clean install. I hate those. If Apple would add a MS like feature (the file you are about to copy is older than one you have...) it would make more sense.
My problem then was this - run OS X install from 9.1. Reboots. nothing. Ok now the problem may be that I have a apple a/v card with dvd-rom. but the os x disk reads fine from both the 9.1 and the osxpb sides. So I come here and read the work around (install from PB without cd..) Got halfway through the only install portion (new printer drivers) and the installer cr$#s out on me with a "cannot continue message". i have to reboot. come back to find it has completely trashed my pb. gone. won't reboot. called apple after 90 minutes of everything imaginable - still nothing. last thing they have me do is boot in OF. great still nothing. but I try back later. OF gives a boot command. I try this. BOOT gives back CLAIM failed. nothing. it sucks.
still waiting for a reply from apple engineers.
suggestions tech support made. pull the ram and try with different modules in... man argggh!
still waiting.
Well, my package arrived about 45 minutes ago.

I've successfully installed on my Beige G3 and I'm up and running with no problems so far. Install was a breeze.......last night I spent a bit of time prepping the drives (backup, restored a couple partitions so I could get my "first 8GB") hitches at all. I did not have to disconnect my 2nd monitor, remove my Initio SCSI card just works.

Now I'm downloading all the cool new software to try omniweb, iCab (using that at the moment).

System: Beige G3 desktop upgraded with OtherWorld 466Mhz ZIF, Initio Miles 9100 SCSI, ATI Nexus128 for the 2nd monitor, 6GB SCSI drive (internal, on the Mac's internal chain), 40GB Maxtor 7200RPM (master on the ide0 chain).....loads of partitions.....
After have tried several voodoorelated trix (different RAM-modules, CD-rom last on cable, first,HD master/slave, formatting UFS,HFS,started from external CD, bla.bla.bla) I disconnected my 4 Gb IDE slavedrive (same chain as CD), then it worked...with one MasterHD and one MasterCD no slaves.
The strange thing is that it worked fine in MacOS 8-9 with One HD as Master on bus 0, one HD as slave and one CD-ROM as master on bus 1, mounted perfectly. The new question is now, if MacOS 8-9 supports a slavedrive i persume that my logicboard is rev b, why do not X support a slave ?

Beige DT 266 (jumperclocked to 300 and back)
4 Gb Original IDE HD bus 0, id 0
4 Gb Original IDE HD bus 1, id 1 (not working)
CD-ROM Original IDE bus 1, ID 0
320 RAM (128,128,64)

How do I know which rev. my logicboard is ?

still no go.
this is after i pulled everything out of the computer including the OWC 256MB Ram I just added.
summary - problem Machine won't boot in OS X (PB/GM) from Apple DVD-Rom drive
1) reformatted and zero'd the 4.0Gb ATA drive to be ready for OS X GM install.
2) clean installed 9.1 on the 8.5 drive.
3) rebooted into 9.1
4) 9.1 says it can't read the ATA drive. Initialize? (YES)
5) select from startup disk control panel 912 OS X CD
6) restart
8) restart 9.1
9) select 9.1 as startup disk
10) reboot with C down
11) 3 seconds floppy icon with flashing ?
12) 0.5 seconds of happy mac
13) automatically reboots
16) still waiting for 48 hour turn around answer from tech support.

I see you've had troubles getting slave drives working....I have had similar problems where booting OSX from a slave drive doesn't work for me. I figured out that OSX will NOT BOOT from a slave drive (CD or HD). You can install TO a slave drive, but you need to set that drive to master after you are finished installing (before booting). I also know that there is an issue with SCSI CD-ROM drives causing kernel panics..
Hey, I was having trouble with os x, and I called apple. Call apple. 1800-apl-care, I think. Check out your documentation. Oh, and beige g3 rev. a power macs can't support a slave drive. You gota upgrade the rom (that thing that looks like a ram dim) to rev. b or rev. c.


Hope this helps, and, os x is worth *anything* short of pitching your mac. Its great. Wonderful. Keep at it, and be persistent with the apple tech support.
It will be a little hard upgrading the ROM in my Rev. C Beige Desktop. I already have support for dual drives on each ATA bus. I am saying that MAC OSX DOES NOT BOOT UP OFF OF A DRIVE SET AS SLAVE BUT DOES ON ONE SET AS MASTER (Only verified on the G3 Beige). Sorry for yelling. I know what you are referring to, and that is not the problem.
I have a Rev Beige G3 and I cannot install OS X (final).

My Beige G3 has two modifications:

1. I took out the IDE CD-ROM and dropped in a 24X apple SCSI CD. I did this so that I could have two IDE hard drives, which I have.

2. Upgraded from 266Mhz to 466Mhz.

I am able to launch the OS X installer from within OS 9, but when the installer restarts I am presented with a panic error that stops me dead in my tracks. I get as far as seeing the happy mac icon, then the panic begins.

Anybody found a work around for this? (other than getting an IDE CD-ROM or getting a new Mac)

After some reading here, I am going to try a few things.....
1. remove all PCI cards
2. remove my current hard drives and add a clean drive
3. look for an IDE CD-ROM, just for the install process.


PS Sorry about the double post in the problems thread, if anyone noticed
mapski, that panic is (I'm pretty sure) being caused by the SCSI CD-ROM drive. Dig up your original ATAPI (or some relatively reasonable other ATAPI drive) and try installing through it.