Magsafe charger - dim green but MBP works


Hi, new member here. I searched after finding this thread using Google:

But there was no answer in that thread and I can't find a similar topic.

MBP, Penryn, with the Magsafe barely glowing green (can only see it in the dark), and it will not go back into charge-mode.

I did dribble perhaps a teaspoon of milk across the arrow/shift/enter keys a day or three before, but nothing happened until I untethered the Magsafe to move it, then when I plugged it back in here's what I have:

iStat battery indicator


System Profiler


Note that the AC charger (Magsafe) is recognized as connected but nothing else. There are normally values here for the Magsafe.


The screen dims when unplugging the Magsafe, as well as brighten when plugging it back in.
The battery has been at 86% for going on 24 hours, but will drain when I pull the Magsafe off.

Machine will NOT boot with just the Magsafe (battery removed); I must have the battery installed to boot. I went ahead and ordered a new Magsafe, but from what I'm reading, that looks iffy.

Any ideas?


It looks as though the battery is being maintained, but it will take more time to say for sure. I say this because when I pull the Magsafe the battery drops into negative Amperage (toolbar), and then when I plug it back the battery slowly values back up to 0 Amperage, which I assume means neither charge nor discharge. And the battery is still at 86% charge and 4 light bars (bottom of battery). If it wasn't receiving some amount of charge it should have dropped.

So, both the Magsafe and the battery power the laptop, but the Magsafe by itself will not. And the Magsafe is keeping the battery alive, but the Magsafe will not boot the laptop nor charge the battery beyond the amount when this happened (88%) or what the battery would drain down to if the Magsafe were removed.

Starting to look like the DC or Logic board (general short).
Good news. A macbook 60w charger worked fine and charged the MBP's battery from 86% to full in about 1:20. The charger's lights (amber/green) worked fine. It wasn't the logic or DC board after all.

Hopefully the end.