Mail.app click on links - not work

MOMkatJ

Registered
I am having a problem with Mail.app:

When I click on the URL address links, the link changes color in Mail.app but does NOT open my browser and follow the link. I have to do a cut/paste to my browser to follow the link.

Mail.app has acted this way since I first installed OS X in March. I have tried trashing my prefs but that did not help.

Anyone else having this problem?
Any ideas on how to fix?
 

Mr_Frost

Registered
I have had the same problem.
Do you use Internet Explorer?
If you use Omniweb it doesn't seem to work. At least not with me.
You just have to make sure IE is set as default web browser in the Internet System preferences.
 

endian

Dis Member
It works fine with OmniWeb for me... Try just resetting the browser prefs
 

MOMkatJ

Registered
Aaaahh! Finally fixed the problem!!!

Thank you, Thank you! Your suggestion of resetting the Browser prefs flipped a switch in my ole brain.

I had set OmniWeb as my default browser but since OmniWeb is not in the pref list, it keeps setting back to BLANK for the default browser.

Last week I had tried using the Terminal to edit DefaultHelperApps.plist but was denied write privileges and didn't have time to try again at the time. I just now tried it again and was able to add OmniWeb to the list. Hopefully, now my default browser will stay set!

 
Top