Mail.app lost all mails

gumse

Member
Suddenly when i started mail.app i was back to day 1 , all my mail and accounts where gone.
In Library/mail I can see that all mails are in their mboxes , but Mail.app can't see them.
I have fsck'd and updated privileges. After that some of my older, imported mails show up, but not my Inbox. The only account left in the program is my mac.com account, my other accounts are gone.

I seem to remember something I read about this problem, but now I can't find it.

Anyone ??????
 

gumse

Member
I made some progress with the mails.
First I want to say that I HAD a backup of the Mail folder, but it was some days old and it didn't help to restore it anyway.

What I finally did was to delete com.apple.mail.plist and to re-enter my accounts in the preferences, that got me back a lot of mail, but not my main account. Then I looked in the Library/Mail folder and found that for some reason the folder holding my account had a slash in the name POP/gumse@host.com and there where also a newer folder named POP-gumse@host.com that where new and created when I re-entered my account. I deleted the new folder and renamed the old one to POP-gumse@host.com , started mail.app again and voila the mails where back !

I guess that the "/" in the folder name screwed something up, but I didn't put it there it must be a mail.app glitch.

I guess the lesson here is to backup the com.apple.mail.plist along with the Mail folder.
 

gumse

Member
The same phenomena re-occurred again a couple of hours later.. scanning for virus right no, but it's probably not a virus, never had one..

This time GraphicConverter and iCal also lost their prefs.
 

gumse

Member
The saga continues.
I have lost prefs from applications (including the Finder) several times after my last post.
Just now i lost all mail prefs again without a restart. I just quit mail and started it again and all account where gone.
When I restore the prefs from backup all works ok again.
 

gumse

Member
fsck = unix command for disk repair.
use it when you boot in single user mode (hold down command s at startup).
I have no problems with any other files, just the prefs files of the open applications, so i don't think it's fragmentation of the disk.
 

toast

Gone !
Okay,thanx for answerin so quick.
Well, if it's not fragged disk, then something BAD is messing the files. No virus, sure ? Any FAT problem ? Tried reinstall ?
 

gumse

Member
Some new observations.
I tried to create a now folder, got an error "no disk space left" , I had 220Mb free on the X-partition, I emptied the Trash and then I had 99Mb left ??????
I logged out and in, now I had 500Mb free and the finder and dock prefs where reset to original state.

I have all prefs on my DotMac backup so it's easy to recover from this, but annoying.

My guess now is that the finder reports the wrong amount of free disk space. It makes sense ,if your disk is full, that the prefs can't be saved.
I will try to free up a couple of GB and see if it helps.
 

roger

Registered
Perhaps your swap file (or some other temporary file) is expanding and contracting, which is why you are getting peculiar disk space messages, and at odd times you are running out of disk space and your settings aren't being saved.

Wierd.

R.
 
Top