Mail is messed up

wicky

play thing
My Mail program is messed up! Can anybody suggest a way to sort it out that doesn't include re-installing the OS?

The two issues are:

1. It no longer displays a little red email count on the dock icon... infact it doesn't notify me about new mail at all!

2. The header part of the emails (where it says who it's from, the subject, etc.,) are disjointed and span half the screen depth. This is a bit difficult to explain, but instead of being 5 lines deep (from, subject, date, to, & attachment), the head section is now more like anything from 20 to 250 lines deep. ..... what can I say, it's broken!

I've tried trashing pref's, but it's still messed up.

Any ideas??
 

cmcclain

Registered
grrrrr, im having the same problem!!! dont really care so much about the red dot issue, but the multiple blank lines in the header are driving me crazy!!!!!!!
 

wicky

play thing
This is a really old thread now, and I had assumed it was an issue that had been sorted out. I ended up reinstalling the whole OS.

There may be an easier way these days though!!
 

cmcclain

Registered
yeah, i had this problem long time ago on my last mac. just got a new G5 2 weeks ago and it has reared it's ugly head again. [sigh]

im thinking it's a font thing. driving me crazy.
 

cmcclain

Registered
it is a font thing. using font book, i disabled all of my personal fonts and started turning on mac OS installed fonts... one group at a time. once i turned on the "PDF" fonts. the mail header issue was resolved.... upon further investigation and process of illimination. it is the "helvetica" within "PDF".

YEAH!

...OH, and it's the "courier" in "PDF" that shows the number of unread emails in the red dot in the doc.

hope this helps others.

cheers.
 

jbarley

One more, for the road!
wicky said:
My Mail program is messed up! Can anybody suggest a way to sort it out that doesn't include re-installing the OS?

The two issues are:

1. It no longer displays a little red email count on the dock icon... infact it doesn't notify me about new mail at all!

2. The header part of the emails (where it says who it's from, the subject, etc.,) are disjointed and span half the screen depth. This is a bit difficult to explain, but instead of being 5 lines deep (from, subject, date, to, & attachment), the head section is now more like anything from 20 to 250 lines deep. ..... what can I say, it's broken!

I've tried trashing pref's, but it's still messed up.

Any ideas??
Check "Mail - Preferences - Viewing"
Top entry "Show Header Detail"
you can customize your headers here, normally set to "Default"

jb.
 

cmcclain

Registered
yes, you can customize your headers in the preferences, BUT if you don't have the installed helvetica open, then mail will display anywhere from 20-250 empty lines within the headers. tried that long ago.

thanks for the tip. :)
 

nicknack1

Registered
My Mail program is messed up! Can anybody suggest a way to sort it out that doesn't include re-installing the OS?

The two issues are:

1. It no longer displays a little red email count on the dock icon... infact it doesn't notify me about new mail at all!

2. The header part of the emails (where it says who it's from, the subject, etc.,) are disjointed and span half the screen depth. This is a bit difficult to explain, but instead of being 5 lines deep (from, subject, date, to, & attachment), the head section is now more like anything from 20 to 250 lines deep. ..... what can I say, it's broken!

I've tried trashing pref's, but it's still messed up.

Any ideas??
hey there, not sure if you have fixed this one yet but i had the same problem for a couple of months and it was driving me crazy.

turns out there is a system font "helvetica.dfont" that must be installed, if you have turned this off in font book or deleted the file with this name things get messed up.

i have multiple users on my mac so i logged in as another user who's mail header was fine and copied the file from the system library to the public folder of the user who's mail was messed up.

i then logged back into the messed up mail users account and dragged the font file into font book... every thing now looks good.

hope this helps.
 
Top