Mail & Sherlock not working


Sorry if it's already know problem, but I'm having problems with Mail and Sherlock.

I have multiple e-mail accounts with different protocols (POP, IMAP, etc.) and while it's accessing to servers, it quits for not reason.

It doen't load the search window. When I go "File" -> "New Window" it gives me an unexpected error thingie.

I first thought it may be a lack of RAM and I added 512MB, but it's still the same. I thought it can be my ports, so I downloaded the latest BrickHouse, but it's still the same (I'm not totally positive that I configured it right, though).

Does anyone out there have the same problems like I do? Any thoughts, input or help is greatly appreciated.
Regarding your Sherlock issues, check out this Technote about the "Unexpected Error" message.

I've had some weird problems with certain apps and I think perhaps deleting your existing keychains might help. It's worth a try, but no guarantees.
Apple *just* migrated their Technotes to the Knowledge Base and you need a password to get in. You can still get the technote using its reference number, which is 106412 (or perhaps n106412).

The gist of the technote is that having a picture on the clipboard can cause Sherlock to get really flaky. The solution is to copy some text into the clipboard before opening Sherlock.

It sounds like this may not work for you in this case since you've had this symptom appear pretty consistently. So another thing I might suggest would be to locate the invisible Find By Content files and delete them all. You can search from MacOS 9 for files that begin with .FCB or you can use the Terminal. This would at least eliminate the possibility that one of these search databases had become corrupted.