Mails Service Failed On Os X 10.3.9

rfuchs

Registered
I created a new account on my server. I check the accounts option in the mail setting and the new user never showed up. Then I noticed that the path that used to be on the server for the mail store says it is unspecified and no one can recieve email. What ever casued this is also causing the server to run the CPU's at max. The CPU usage stays around 98%. I have all the latest updates and have stoped the mail service and restarted and shut the server down and turned it back on. as soon as the mail service starts, it begins to eat up the system again. Our local mac service has come and ran disk warrior utility on it and it did fix a volume problem but the mail is still not working. I had our internet provider come and take a look and he said the all our mail is coming in and being stored but what ever program sends the mail to the users is currupted or damaged in some way. My question is: can this be fixed? or do i just need to reinstall the system and loose everyones email that has come in since the service has been down. Which is going on three days now. I have been on the phone trying to get ahold of apple support. Its been 2 and a half hours so far and I still have not been able to talk to anyone. Does apple even have tech support? anyway i would appreciate and help anyone can give me.
Thanks,

Robert Fuchs
 

xaMdaM

Registered
Robert,

I just got through encountering the EXACT same thing!

I finally came to the logical conclusion that it's a problem with 10.3.9 Server upgrade... Remember when there was a rash of screams when it came out for workstation!?! The 10.3.9 update was canned and re-released a few days later... as well as the combined updater was made available as a download... (Is that the smell of 3 day old fish I'm smellin'???)

Ended up being quicker to reinstall 10.3 and reset/rebuild the server. It's the ONLY thing that got the server working again. I rebuilt permissions, reconstructed the /var/imap and still nothing worked correctly... Eventually I got the mailboxes rebuilt, but passwords were reporting bad and couln't reset them.

Accordingly, when delving into the bowels of Apple KB, I found references for Server 10.3.8 (and earlier) and 10.4 (and later) but no relative info on virtually any aspect of 10.3.9. (hmmmm, yup, it's DEFINITELY 3 day old fish!)

After the 10.3 install, I will NOT have anything else to do with 10.3.9!!! My gut tells me it's just plain buggy and not worth the hassle.

Max
 

Kees Buijs

Registered
xaMdaM said:
Robert,

After the 10.3 install, I will NOT have anything else to do with 10.3.9!!! My gut tells me it's just plain buggy and not worth the hassle.

Max
If you look back in the history of the site you will find that i reported the same problem after installation of 10.3.9 update on a perfect running 10.3.8.

After calling to apple tech (and telling them i expect support although i would not get it because i bought to long ago) they helped me and got it more or less running.

The main problem is a change in the LDAP record structure, which should be fixed (after a very long processing time).

Apple made a document on this: 301384 on the Apple site “www.apple.com/support”.


I ended up re-installing 10.3.4 and upgrading to 10.3.9 (it is oke as long as you do it before creating any users using LDAP).

Before re-installation you should backup the map 'var/imap/spool'. This map contains you mails. You can rebuild the required databases using the following document from apple: 107996 on the Apple site “www.apple.com/support”.

I modified it slighty so it works a little better:

su
mv /var/imap /var/imap.old
mkdir /var/imap
/usr/bin/cyrus/tools/mkimap
chown -R cyrus:mail /var/imap
chown -R cyrus:mail /var/spool/imap
sudo -u cyrus /usr/bin/cyrus/bin/reconstruct -i
sudo -u cyrus /usr/bin/cyrus/bin/cyrus-quota -f

(if not already logged on as superuser (su), than paste the script twice in the terminal).


After a proper installation of 10.3.9 i was pleased with it, but not with the way apple made me use it.


Gooed luck, Kees
 
Top