major iphoto 5 problem

Not open for further replies.


i created a thread a while back regarding this issue and it has still not been resolved. i've tried everything i can think of. here is the history.

- i bought the powerbook with panther.
- moved iphoto from default location (worked fine).
- upgraded to tiger (iphoto still worked fine).
- deleted (by mistake).
- re-installed iphoto from panther disc (tiger doesn't include it).
- iphoto starts and says "loading photos..." with pinwheel, forever.
- tried software update to iphoto 5.02 but received the message that "there is not a valid iphoto application installed"

i've tried deleting the library, rebuilding the library, repairing permissions, and many other global fix issues, but nothing is quite as telling as the fact that the panther-included iphoto is somehow unable to install within tiger. perhaps something is not binding correctly.

suggestions ?

iPhoto update 5.0.2, I believe is an update for iPhoto 5, and most likely you have an earlier version, maybe 4.0.

Try trashing the iPhoto preference file -

located in user>library>preferences
And btw.: If a thread doesn't give an answer, there's still no need to create a new one... :) Just re-use your old one with the same problem.
Not open for further replies.