MBP won't boot/ keeps restarting/ Tried everything... PLEASE HELP!!!

sccrawle

Registered
Hey folks,
I know there have been similar posts on this topic, but nothing has cured my problem yet. My macbook pro (2.4Ghz, intel core duo) was working just fine with Leopard when I bought it from a friend. Not being a fan of 10.5, I decided to downgrade to 10.4 considering my iMac, and fiance's macbook pro both have Tiger installed.
Anyway, for some odd reason the new MBP wouldn't boot from our Tiger MBP install disk (it kept restarting while I was holding the C key). I thought that was strange because both laptops have intel chips, and since they are both "machine specific" our MBP disks should have worked with it.
I suppose I could have done some more research first, but I knew it was possible to connect via firewire and install Tiger through target disk mode. I clicked install on the external HD, it verified the disk in the working MBP drive, and said it was good to go. After installation was complete, I properly disconnected the two laptops and powered up the new one. The standard chime and apple logo appeared, but shortly after that the screen went black and shut down. I was about to push power again, but it started by itself and chimed with the apple logo again. It kept doing this over and over until I got annoyed and powered down.
I tried to boot up in single user mode. It looked like it was working at first, but then I noticed it wasn't the normal protocol on the screen. There was the usual fast jibberish at first, but then several dots started scrolling across the screen, as if someone were holding down the period button... then it turned off again.
I tried booting up in verbose mode, cmnd x, and safe mode, but still the same results. I also reset the PRAM and PVRAM, took out the battery and tried with only AC adapter, but no dice. Then I held option during boot up. I had the Tiger install disk in, and both the HD and disk showed up. I thought I was finally in business, but clicking on either icon envoked the same restarting issue!
The only other thing I could think of was that something was wrong with the drive itself. I hooked up firewire with command T again, and ran disk utility... everything came back fine. At this point I called the previous owner, and he said that his ex-girlfriend might have put a firmware password on it. I didn't think that was really an option, considering intel powered macbooks have EFI now. But after scouring the ends of the internet, some people were saying that my last hope would be to pull out a RAM chip, reset PRAM, put it back in, and I should be back to normal. Did that... still no boot up.
Does ANYBODY have a clue what's going on??? I heard that it could be a bad logic board, but the symptoms don't really seem to match up (from what I've read atleast). I've been using macs for almost 2 decades now, and I have always felt comfortable finding my way around. But this has gotten me so lost that I'm gonna rip my hair out! Unfortunately I don't have applecare, and I'm sure some of my troubleshooting up to this point has voided any warranty. I suppose I could take it to the geniuses at the Apple store, but I was hoping that there would be some geniuses floating around here that might be able to save me from Apple's repair costs.
Thanx for reading this long novel of a post, but I really wanted to be thorough. Any ideas would be greatly appreciated.

Respectfully,


Scott
 
Top