Mini - Added SuperDrive stopped reading some DVD-R

Robn Kester

I heart nothing
I have a Mini running 10.3.x that I added a Pioneer DVR-K40L (I think thats the right model #) to when I got it. The drive just worked like a charm when I swapped it in for the CD-RW/DVD ROM that was in it originally.

Then a few weeks ago my HD in my Mini went haywire, and I had to attempt to get the contents off and reformat it to save it.

In the process, I obviously had to reinstall OS X from the disks that came with the Mini. And now my SuperDrive no longer reads DVD-R created on my Mac. I can put a DVD-R into it that itself actually burned (with toast 6), or that were burned on my G4 and it spits them right back out. The same discs work totally fine in the G4, in my PC, etc. So I know they are totally valid.

I went back and found some older DVD-R I burned and had used on that same Mini and they also would just spit right back out.

BUT a DVD-R burned on a friends PC read it fine.

Only thing I can think is that the drivers for the drive did not load correctly for whatever reason when I reinstalled. But i have no clue how to reinstall the drivers for the newer drive. I am seriously considering putting the original drive back in and trying to get it to work, then reinstalling the newer SuperDrive.

I just cannot be without DVD-R reading, as this is how I do almost all of my backups. And I am pretty sure its a driver issue so I should be able to fix it.

Any thoughts, clues, hints, pointers, etc on how to make this problem a non-problem?

As said in another thread, the problem was the haywire HDD. I replaced it Wednesday night and everything is working honky dory now.
Correction. I have been playing with it some tonight and found the following...

It will read/play any DVD-R formatted in HFS Extended, ISO9660, commerically pressed DVDs in any format. But will no longer read any DVD-R I have made on this or my G4. Not sure what the problem is, but I have to be able to read DVD-R, as that is where my backups are saved.

Which means I either put the original drive in when I need to restore stuff, or I stop using DVDs which is silly.

I tried patchburn, it said my drive was supported fully in the OS. I am hoping when I upgrade to Tiger the problem will go away or I will just have to get rid of the drive and find a new one that does work.

Anyone who might know why my DVD-R burned by me would be no longer working, please chime in. Is it possible Apple patched the OS to knock out this support so I'd have to buy their burner?