MO drive / media not recognised

Thomas Ganter

Hello world!

I have a beige G3 with an external SCSI MO (magneto-optical) drive.

Up until 9.1, everything works fine with this drive and the media I create. Inserting a disc will pop up an icon on the desktop, putting it to the trash will eject it.

Starting from X (10.0.4), my drive will somehow not really be recognised.

These are the phenomena:

- If I boot OS X with a media inserted, the finder will be super-slow (yea, even more slow), and after 5-10 minutes the media will get ejected.

- Inserting a media will not mount it.

- The drive does not show up in the DiskTool. However, the DiskTool hangs whenever the drive is connected.

Does anybody know where I get drivers for a MO drive?

- Thomas


Dis Member
Is the media you're inserting HFS or HFS+ formatted? I have an ancient 128MB SCSI MO drive that works fine.

Thomas Ganter

Hi endian,

the media I tried were HFS formatted (I think). I purchased DosMounter some time ago to do the MO formatting (DOS compatibility and stuff).

But all the Media mount under OS9 even on machines that do not have DosMounter installed.

pdisk also shows no information on the media.

The drive itself is a 640 MB drive. I tried also 256 MB media.

When I insert unformatted media, sometimes (not allways) I get a 'unrecognised volumes' message that asks me whether I want to format the thing.

Selecting 'initialise' will only freeze the system.

- Thomas


Thats real interesting, I have a Toshiba CDRW/DVD internal in my G4/400 which works fine under 9.1, is recognised by Roxio Toast in OSX but OSX will not recognise any CD's put in it. Been trying to find out whats wrong without any success so far.