Modem does not respond in OS X 10.1

flaming_pig_boy

Registered
I just upgraded to OS X 10.1. Unfortunately now it won't recognize my modem or some damn thing. The modem still works fine in Classic, and worked fine in 10.0.4 (internal 56k in B&W G3)

now, as if like some curses magic has worked, OS X won't connect to the internet. the modem doesn't actually seem to do anything. As if OS X 10.1 completely ignores it.

I really don't want to reinstall it. I think that is my next course of action though. That, perhaps, is deserving of a face icon: :mad:
 

ethereal

Registered
The answer is rather simple (and yet annoying). I had the same problem with X.1 when I first got it. After beating myself up for about a day, I finally realized why. You have to be logged in as the root user in order for your modem preferences to work properly. Once the preferences have been made, make sure to select on "Save Password" on System Preferences<Network<PPP so that you can log in as the regular user and still have access to the i-net. That's It!!! (By any chance, do you have Earthlink? If you do the same is true with their new installer package, you can only run it as the root user). Good Luck! :cool:

PS Do you know how to enable the root user? If you don't drop me a line!
 

flaming_pig_boy

Registered
Yes, interesting indeed.

what i actually did to remedy the problem was replace my OS X modem script with the modem script in OS 9.

but i just installed Mac OS X on my other hard drive because i am in the process of making my current hard drive for OS 9 (the other one's bigger, faster, hell; its just going to make me happier) i will try logging in as the root user and doing it your way.

"two seperate stones could very well kill the same bird." or.. "birds of the same make and model could equally die by different stones" (since you couldn't kill a bird that was already dead no matter how big a stone you had. mutilation: maybe/probably. death: no.)

Seth
 

callieX

Registered
So what you are saying is to login as the root user rather than yourself the administrator from the GUI. Then bring up the modem preferences and set it up. I am running OSX 10.1 on my G3 266 powerbook with built in modem. It works fine on 9.2.1 but not in OSX. I tried setting it up to work for ppp. In OSX it continues to dial the phone even when I click on disconnect. I had to pull the batteries out to get it to stop. I hope your suggestions helps.

CallieX
 
Top