More Beige G3 OS X wierdness

Hello,

I haven't seen this particular problem regarding OS X installation on a Beige G3.

-Beige G3 233 Rev A with OWC 400 mhz zif upgrade
-Hard Drive upgraded toMaxtor Diamond Max Plus 13.6 gb
-OS 9.0.4, with all updates installed (most recent CD update install was disallowed, not applicable).

When I attempt to boot from the OS X install disc (either by holding the "c" key or selecting it as the startup disc, I get a BW command line screen which reads as follows:

Default Catch code: FF00700 at %SARO: 01c00c00 %SARI: 00083070

Open Firmware 2.0f1
TO CONTINUE BOOTING MAC OS type BYE
(this causes the mac to boot OS9
FROM DEFAULT, type BOOT:
(this causes to fail to boot and return to the prompt)
FOR OPEN FIRMWARE Serial I/O, it suggests another input (which I forget, but which crashes the machine)

Anyone else seem this? Any ideas?

Thanks,

MG
 

Pascal

Official visitor
It appears that many disk driver's license is not valid under OS X, so the only one that you can use is Apple's. Maybe is it the case for your drive ?

See dfour's experience in this forum.
 

iconara

Registered
I'd guess it means that open firmware couldn't find os x. I got the same message when I removed Darwin and tried to restart and also when I removed Mac OS X and tried to restart. the solution then was to zap the PRAM (alt-cmd-p-r at startup), then it started in os9 again. but, you want to start in osX... anyway. I'd guess just as Pascal that it has to do with your HD drivers.

theo
 
Think I'm gonna throw in the towel, I just can't believe this can be made to install on a rev A Beige G3 with a zif upgrade.

I've put the original hard drive back in the beast, upgraded to 9.0.4, run hard drive setup to make sure the drivers are current. Now, when I set the startup disc to the OS X cd, or use the installer to set it to start the install, the same thing happens...a brief flash of the "can't find startup disc" icon, then a disc icon, which hangs and hangs and hangs.

For what it's worth, I think it's _almost_ getting there, because the happy mac icon wasn't the same as when it boots off the hard drive. So maybe it's sorta kinda finding something. Yeah, maybe it'll work next time.

And maybe I'm a chinese jet pilot.

Sigh.
 

Pascal

Official visitor
You found the culprit, only you did not realise it : you have an upgraded Mac, so the OS, not having succeeded in positively recognizing the Mac config, refuses to boot.

Right now, OS X is much more finicky than OS 9 : the only thing the latter required to boot was a Motorola CPU and an Apple ROM (well okay, I maybe a little bit to simplistic here ;)). The present Mach kernel implementation limits the number of hardware variations that are acceptable for OS X. Does power come at a cost ? I truly hope that maturation will give OS X the suppleness of its grand daddy OS 9...
 

BobB

Registered
Not true.

I'm running a Rev. A Beige 266 MHz G3 MT that has been upgraded to 224 MB RAM and a copper IBM 500 MHz chip from OWC, plus 4 external SCSI drives. Works just fine.

My only major problem has been Classic, which aborted whenever launched. So I used Conflict Catcher to create a new default set without a ton of non-Apple extensions for MacOS 9.0.4, and now MacOS X launches Classic without any problems.

One other problem has been in my choice of disk partition names. I have 4 hard disks (3 - external SCSI, 1 - internal ATA) that are all partitioned (about 18 partitions in total). All of my software resides on a partition named Applications.

MacOS X is unable to see it's folder named Applications whenever my disk partition named Applications is mounted. So I am having to rename my partition (and fix a lot of broken alias to the partition named which I have renamed Software).
 

Pascal

Official visitor
I have since learned that if one upgrades a G3 with a G3 via a ZIF card, there will be no problems installing OS X.

But if one upgrades a G3 to a G4, one cannot boot in OS X : some new drivers are required.

Of course, in theory at least, one cannot boot into OS X if one has installed a G3 upgrade into a pre G3 Mac. Some people seem to have been able to do so, however.
 
Top