Mount as Drive Issue: Amazon S3 + Transmit 4


Tech-Bot 5000
Hi, having a strange issue because this used to work at one point.

I'm doing the following:

1. Connect to my Amazon S3 account with Transmit, using Mount as Disk option
2. The account is set up and I can access it normally via FTP and I have one bucket there

What's happening is:

1. I get this error: Internal error (rc=1) while attempting to mount the file system. For now, the best way to diagnose is to look for error messages using Console.

Not being very good at the console, I'd love some help with this. Here's the console error. Only the bottom message applies as that's when I actually tried this scenario, but included previous messages just in case:

Oct 6 15:18:43 dirtandrust Transmit[262]: Called BW factory
Oct 6 15:18:43 dirtandrust Transmit[262]: Allocating me
Oct 6 15:20:09 dirtandrust firefox-bin[274]: Error loading /Library/Audio/Plug-Ins/HAL/Digidesign CoreAudio.plugin/Contents/MacOS/Digidesign CoreAudio: dlopen(/Library/Audio/Plug-Ins/HAL/Digidesign CoreAudio.plugin/Contents/MacOS/Digidesign CoreAudio, 262): no suitable image found. Did find:\n /Library/Audio/Plug-Ins/HAL/Digidesign CoreAudio.plugin/Contents/MacOS/Digidesign CoreAudio: mach-o, but wrong architecture
Oct 6 15:20:09 dirtandrust firefox-bin[274]: Cannot find function pointer NewDigiCoreAudioPlugIn for factory B8A063B5-2F3D-444A-88CB-D0B8F1B22042 in CFBundle/CFPlugIn 0x17347c00 </Library/Audio/Plug-Ins/HAL/Digidesign CoreAudio.plugin> (bundle, not loaded)
Oct 6 15:22:36 dirtandrust ntpd[26]: time reset +0.663494 s
Oct 6 15:24:06 dirtandrust /usr/sbin/ocspd[287]: starting

Any ideas on how to get this to work, or a better app than Transmit for this?


In Geostationary Orbit
Well OS X only READS FTP, not write. Hence all the third party applications. This slickest ftp software I have seen (that also does Amazon S3) is ExpanDrive. You might would want to look at that to see if it is what you want.



Any chance you could post ur thoughts re: tools? I am about to embark on a test of the both myself.

Interarchy! Still around, wow!


Tech-Bot 5000
I've tried:

1. Transmit
2. ExpandDrive
3. SME

I like transmit the best because of it's Mount as Disk option is so much better than SME (SME's drive icon is naff and the connection is clunky).

Use the latest version of Transmit or the Mount as Disk won't work. They had a release that broke the feature but have since fixed it.

ExpandDrive has the best upload progress of any of them, you can see by directory or even by each file.

Transmit is the winner!