mounting a cifs directory

holmBrew

Official Volunteer
i tried to mount a cifs directory the same way i mount an nfs directory but it did not work...i was return something like mount_cifs not found...

how do i do this?

-Jason
 

Straylight23

Registered
Simply speaking, you cannot. MacOSX lacks kernel support for smbfs. It is part of the Linux-kernel since kernel since 1.something but not of the Mach-microkernel used by MacOSX. There is a commercial package called "Sharity" wich fills that hole. If you are short of money, you can go the other way round and install <a href="ftp://techhouse.org/pub/osx/samba-2.0.7-osx.tar.gz">Samba for MacOSX</a>. This will turn your MacOSX-box into a Samba-<i>Server</i>. But not into a client...

cu:Stray
 

tismey

Official Bartender
As long as you're only using it for home/non-commercial use, you can get a free OSX licence of Sharity and mount CIFS shares. It's a piece of piss to set up, it really is.
 

Straylight23

Registered
These are the filesystems known to MacOSX:

[localhost:/] straylight% mount_
mount_afp mount_devfs mount_mfs mount_synthfs mount_webdav
mount_cd9660 mount_fdesc mount_msdos mount_udf
mount_cddafs mount_hfs mount_nfs mount_volfs
[localhost:/] straylight% mount_
 

holmBrew

Official Volunteer
thanks for the input...

i tried sharity, but the free license limits you to one subdirectory which SUCKS!

i monder if mount_msdos will do it?

-jeh-
 
Top