mounting nfs drives

littletiger12

Registered
I have a PC running Solaris 2.7, i have a share drive using the share command, this allow me to share a nfs drive

i can't get MacOS X to mount the connection.

Any body know how ?

Warren
 

holmBrew

Official Volunteer
I've learned there are a couple of ways to do this, one using NetInfo Manager and the other using the CLI, the NetInfo route is a bit more reliable and hands free on OS X, in my opinion.

Before you start you may want to confirm that your Solaris box is actually exporting correctly or that it is set up to export to your IP space. From the CLI type:

showmount -e www.yourNfsServer.com (or the IP address of the nfs server)

this will sow you a list of volumes and what IPs they are exporting to.



1) open NetInfo Mgr.
2) authenticate
3) select the mounts directory
4) click on the the "add new directory' icon and type Cmd+n
5) Using the Directory menu add the following properties and values to the ne entry

Property.....................Value
------------------------------------------------
name ........................ myNfsServer:/mydir/
type .......................... nfs
dir ............................. /the/mount/point/of/the/shared/volume/

6) Cmd + s to save or File>Save
7) Deauthenitcate
8) Try loggin out to incorporate these changes, but I have always had to Restart

 

littletiger12

Registered
I did what you said, the showmount -e namenfsserver

I add the netinfo

save

reboot

then it hung on starting file system, don't now how to make it skip it so I can change the netinfo any Ideas
 

holmBrew

Official Volunteer
hmmmm...

try unplugin it from the netowrk and restarting...maybe then it will think you don;t need to start nfs because there is no other network except for the loopback.

-jason
 

kilowatt

mach-o mach-o man
I did the same thing with my red hat box. I configured mac os x to mount the volume on startup, but I haden't configured the redhat box correctly. I needed to add a line to /etc/hosts.allow for my computer.
portmap : 192.168.1.0/255.255.255.0 : allow
I think solaris will be different because it may have a different pam or something.
Also, the only way to make your computer boot up now (asuming that the nfs connection fails on startup), is to boot holding apple-s. That gets you in to single user mode. Then mount your file system just like in the instructions you are given. Next, you have to figure out how to use nidump and niload to remove the netinfo domain you created under mounts. Its quite annoing, so I gave up and fixed my redhat box.

Another thing I just realized, you may be able to simply remove it from startup by removing the files in /System/CoreServices/StartupItems/mounts/

really, all you need to do is remove the 'mounts'. It might be labeled differently, maybe as nfs or something. But if you remove it, then it will no longer be accessed on bootup.
 

holmBrew

Official Volunteer
I've not had any problems with my set up, and I did everyhting with NetInfo Manager. You can also delete the mount with NetInfo Manager, which I think is safer than doing it from the command line.
 

kilowatt

mach-o mach-o man
Well, when boot up fails, and only single user mode works, its kinda hard to get into the netinfo manager (you are at a shell prompt, with no gui in sight).

At least thats what I was faced with.

I think I'm lucky that I got my linux box to work. If I haden't of been able to, I probably would have really messed things up trying to remove the domain via command line.
 

dennisj

Registered
I followed holmBrew's concise directions to enable an NFS mount. Didn't work!

I ran showmount -e to make sure I could see the exported dir.

In NetInfo Mgr I created a new mount

name = meth1:/methods/
type = nfs
dir = /Volumes/methods/

During the reboot I see nfs starting, but the nfs device is not mounted after the reboot.

Any idea why this is not working?

Dennis
 

holmBrew

Official Volunteer
I have not been sucessful mounting in Volumes. try mounting to a directory within your home dir
 

raxa

Registered
from what i have heard NFSManager is it when it comes to mount nfs volumes in Mac OS X.

download it from version tracker.

i have not tried it myself though.:confused:
 

holmBrew

Official Volunteer
NFSManager is just an app that is suppose to make it easier to set up mounts. I thought it was rather confusing you can also try it from the command line.

mount -t nfs my.nfs.server:/my/home/dir/ /my/mount/point/
 

meharrington

Registered
Hey all,
When editing net info use the following:
Property | Value(s)
-------------------------------
vfstype | nfs
dir | /mnt
name | nfs.server:/dir/
opts | net, -P, -b, -s

net makes the nfs automounter take over and mounts it in /private/Network/Servers/

-P is NOT ignored as said in the man pages and is needed when connecting to Linux box's and probally other UNIXs too

According to the man page:
-b If an initial attempt to contact the server fails, fork off a
child to keep trying the mount in the background. Useful for
fstab(5), where the filesystem mount is not critical to multius-
er operation.

This prevents your computer from freezing if there is a problem with the export.

Good luck,
mark

PS I might have changed some other stuff so if this doesn't work let me know
 

zeppo

Registered
hi all
- i don't know if you know this, but there's an excellent article about mounting nis (and nfs) at: www.bresink.de/osx/nis.html#Versions
- at the moment i'm trying this, there's just ONE damn thing that doesn't work for me:
after i have set up the lookupd.txt, saved it and getting ready to put at the end of the string /locations/lookupd using the two commands
niutil -create . /locations/lookupd
and then
niload -r /locations/lookupd . <lookupd.txt

i get a
token "-nil-2 error at line 24 (and in the script there is no nil at line 24)
- what gives?

if this works it should be possible to access a user db from the unix server, complete with directory and all!

hope this either helps or brings some more confusion :)
 

zeppo

Registered
first problem solved - apparently had a typo in there somewhere - bu still nothing is happening. I read somewhere that it was neceesary to generate a mount map for os X on the server side, since the nis automount is very different from the os X automounter, but i haven't tried it out yet - any experiences?

zeppo:confused:
 

kilowatt

mach-o mach-o man
have you tried booting in verbose mode?

power up and press (and hold until you see it effect the system) apple-v. You'll see *everything* as it happens.


Also, try running a packet sniffer while you boot, and have the sniffer save everything into a file. (doing this durring software update is also interesting...)


on solaris, do # snoop -o snooped.tx
mac os x, $ tcpdump -w dump.tx


I could be wrong on those, but man pages rock!
 

Straylight23

Registered
Originally posted by holmBrew
I have not been sucessful mounting in Volumes. try mounting to a directory within your home dir
My NetInfo-entry looks like the attached file.
On the Linux-box i had to edit /etc/hosts and /etc/exports.

<pre>
/etc/hosts:

my.ip.add.ress titan-x

/etc/exports:

/home titan-x(rw)
</pre>

I retstarted inetd and nfsserver on that linux-box and finally rebooted my OsX-box... Voila.. a perfect mount accessible through the finder with no errors or quirks...

HTH

cu:Stray
 

Attachments

Top