Mounting Windows NT/2000 Volumes in OS X

darksun

Registered
I have a big.. big problem.
I'm currently running OS X 10.1 (build 5G64) and i cannot mound Windows NT 4.0 / 2000 volumes via AppleTalk (all the PC have PC MACLAN or the MacFile service activated)... it's a bug? What i can do?
:confused:
 

kilowatt

mach-o mach-o man
What *exactly* is happening when you try and connect, and what procedure are you using to connect or discover the pc computers?

Oh, and 10.1 is supposed to be able to connect to standard winblows file sharing, if you can wait.
 

ulrik

Registered
I am connecting to windows file sharing systems with 5G64 without a problem.

Pre-10.1 versions of MacOS where only able to mount the latest versions of Microsofts Appletalk supported OS, so Windows 2K Server and Advanced Server where able to share volumes MacOS X could mount. MacOS 10.1, however, is able to mount ANY volume shared by a Windows system. Just get the IP from the system, make sure the user privileges are set correctly and use "Connect to server..." and enter the IP. Works for me. Still, I am very dissapointed that you can't automount volumes at startup..
 

Lazarus18

In debt medical student
I couldn't connect to my 98 box via samba, and it turned out to be something DAVE had done. Not sure if it would affect appletalk or not. Try running the installer for Dave again and use the uninstall option if you had it running under 10.0.4.

-Rob
 

Qattara

Registered
I have just installed 10.1 and am unable to mount my W2k Server volumes. The same problem has occured on both my macs running 10.1. If this is a bug, I can't belive this bug was allowed to ship! So much for running to the Apple Store today!
 

hugheba

Registered
I've been able to mount my win2k Server shares.

You have to give the share name also.

Unfortunately typing smb://10.0.0.1 won't bring up your server shares.

You have to actually specify the name of the share.

smb://10.0.0.1/myshare

Doesn't look like 10.1 can see or searches for the shares on the server itself.

On the otherhand I have Appletalk installed on my win2k Server and am not able to get to it through Appletalk. I boot up in 9.2 and network browser sees it fine. For some reason it says in 10.1 that it doesn't see any shares for that server although it does see the server.
 

kenny

Registered
Originally posted by macvillage.net
Ok I entered this:
smb://192.168.1.3/win

Server returned error: 1

why?
Because the SMB functionality in MacOSX <-> Windows is kinda broken. SMB expects the called name to match the NetBIOS name of the client, else it all falls apart.

For instance, my laptop, 'propaganda' was leasing an address from dhcp, and had no entry in DNS, so was only accessable vi IP address. Entering smb://192.168.1.236/wap failed with error 1, as you describe.

Next, changed the IP address to be static, and match its (old) entry in DNS, entering 'smb://propaganda/wap' worked just fine.

Futher evidence of what's going on here is found in /var/log/system.log when trying to map via IP address:

Code:
     Sep 29 22:41:38 turlingdrome mach_kernel: smb_maperror: NetBIOS name is invalid
Nice, eh? And to top it all off, error 1 seems to occur at the slightest error too - like, say, mistyping the password. Fat lot of help that does.

And it looks like NFS is just as twitchy from Finder as SMB is.

Not that I'm complaining, exactly. I mean it beats the heck out of Chooser, and it's a LOT more than Windows can do... ;)
 

ilo

Registered
Hmm. Quite disappointing.. However, I upgraded to 10.1 from my 10.0.0 with Sharity installed, and when the machine launched 10.1, there was a "CIFS" icon already mounted on the desktop! This was all without running the Sharity client app (?), only with the 'startup items' component of sharity installed... you might want to try this.

IE:

Download Sharity.
Drag the 'startup items' folder to the 'library' folder.
Reboot.

This will essentially be the same to what I had initially. BTW I just uninstalled Sharity to see what exactly the built-in networking capabilities are; it seems I'll go back to Sharity.
 

phylaxis

Registered
:( I am suddenly getting the Error 1 on one of the SMB volumes that I was able to connect to in the past. I can still connect to all the other SMB volumes on my network. Has anyone else had an issue like this? I have tried using both the volume name and IP with the same results.

-Phyl
 

sinebubble

Registered
kenny,
put the ip address and hostname in your /etc/hosts file and you'll be fine.
 

phylaxis

Registered
I tried adding the IP/Hostname to my /etc/hosts, but had no luck. I still get the "server returned error 1" message. The stange thing in my case is I was able to connect once and then never again. :confused: Any ideas?
 

sinebubble

Registered
Phyl,
I had problems initially trying to mount Win2K shares. I found that there couldn't be any spaces in the share name (be careful for other illegal characters -- this is Windows afterall) and that the ip number and hostname had to be in my hosts file if the system wasn't in dns (wasn't able to access the system with just ip number). Once I had those two things fixed, I was able to get a domain/username/password prompt, leading to a successful connection. Also, I believe you can only have 2 shares mounted at one time.

Sprinkle rice on the floor and do the chicken dance, I guess.
 
Top