Mpeg2 Option Not Available In Finalcutpro Or Quicktime


I am using osx 10.4.1 and I have final cut pro hd. I do not have the option to export to mpeg 2 (only avi, mpeg4, etc) and after some research I found that I need the quicktime mpeg 2 codec and that that can be achieved by upgrading quicketime to pro.

I tried upgrading using the key that came with final cut but I figured out that that was for quicktime 6 only . So, I purchased the key to quicktime 7 to upgrade to quicktime pro in the hopes of exporting to mpeg2.

No luck. I have tried uninstalling fcp and dont have any luck there. I tried uninstalling quicktime (based off the instructions in the forum (that was how I discovered you guys..;) and I have had no luck there (the quicktime installation program says it needs a version of ox older than 10.3.9.)

I have tried copying the quicktimempg2.component file into library\quicktime as well as into system\library\quicktime. Ive even copied it into my directory under the user.

I'm very stuck and getting frustrated.
Please help.