Music Sync To Iphone With Ios 8



Got a bit of a shock whilst syncing my iPhone music, to see that suddenly the space available on my phone has gone from 10+ gigs to 3 gigs. Upon closer examination, I now see a bunch of playlists that I had not previously selected, present and obviously sucking up the space.
When I select the "Music" tab, all that I see now is a message telling me that iTunes Match is on... and there are no longer any selection possibilities.

What can I do to regain control of my iPhones music content?

Just to add to this post.... Yet further investigation has revealed that some glitch has now duplicated the majority of the songs, further clogging up my music listings.
Open iTunes and turn off Match/Sync. You will need to connect your phone to your computer in order to see that option.
Thanks Cheryl...

I turned off iTunes Match from the "Store" drop down menu.. But that has not made a difference to what I'm seeing when I click on the "Music" tab in the iPhone selection in the main iTunes window.
It is insisting that iTunes match is on, even though I have restarted iTunes.
Can you list a step by step, as I'm clearly missing something obvious!



ps. and in another twist of the tale... After another sync attempt, I now have 8+ gigs space avail, but all my music is now only available to me via the cloud..... Arrrggghhh!
How do I get back to being able to select what music that I want, and being able to have it physically transferred to my iPhone.... To be able to play it back without downloading it back from the cloud?
Last edited:
Now that you have the Match turned off, make sure you are in the Phone pages of iTunes (click on the iPhone button at the top right) and click on the Music button in the menu bar.
Under Sync Music, select Selected Playlist, etc not the Entire Music Library.
Now you can select from four categories - Playlist, Genres, Artists, or Albums.
Click on Apply
Then click on Back Up in the Summary
Watch that free space open up :p
Hello again Cheryl...

I've given this some time just to be sure.

This is what is happening now & previously.....

-iPhone plugged into MacBook Pro.
-iTunes open, iTunes match selected OFF and iPhone tab clicked.
-"Music" selected from iPhone menu bar.
-"iTunes match is on" message appears.... And I still cannot select anything.

I have repeated this process multiple times with the same result. If I didn't know better, I would think that I cannot turn off iTunes match even if the system says that I have.... Surely this cannot be the case?!

Yours in fading hope...


Check the setting on your phone (scroll down to Music). At the very bottom is Subscribe to iTunes Match. Turn that off.
Thank You..... Please excuse my dotishness... The answer was very simple, if you know where to look.

I have one last issue tho'.... after selecting only the stuff that I want (music, photo's etc) my phone now shows that I am some 203 MB's over capacity with some 11.42 GB's attributed to "Other"!
Having checked all the iPhone menu buttons, I am unable to discover what "Other" means/is, and how do I get rid of it?

Regards again,

One Question - Did you connect to iTunes, Select the music you wanted, click on Apply, then Sync?
Other is the iOS files - system files, etc.
Yep... I did all that.

Just to be sure, I did it again.... And the problem just got worse! I now have 20+ Gigs of "Other", and am now over capacity by 9+ Gigs.

Music - 10.86 Gb
Photos - 2.3 Gb
Apps - 2.92 Gb
Documents & Data - 63.5 Mb
Other - 20.29 Gb

This cannot be right.


Hello again Cheryl...

After days of fiddling around with no change, (how does 20+ gigs of "Other" suddenly appear anyway??) I decided to start from scratch, as it were....

I restored my iPhone and reloaded from my computer backup.

I'm happy to report that this has worked! I'm now back to 13 gigs of free space with "Other" only occupying 1.13 gigs.... Much better.
Have no idea how or why all this came to be, but I'm glad it's now resolved.

Many thanks for your time and effort in assisting me.

Take care & regards,