My Finder keeps quitting (every 2 seconds!)

granthac

Registered
It started with just a few random applications quitting on their own, then I get the "submit a report" screen. When I went to restart my finder would launch after boot up then quit, then launch and quit. I tried to safe boot but with the same results. Now when I start up I get the grey screen, then a half second of a file with the finder icon (i only saw a question mark in the file once) before it goes through the normal boot up. Then the quitting begins. I ran disk warrior to no avail. Does anyone have any ideas? Thanks in Advance!
-Chris
 

fryke

Moderator
Staff member
Mod
Do you have APE and/or any haxies installed? Any third party OS X themes? If so, remove those before trying again. Also: Try with a fresh user account, if you manage to create one, and see if it happens there, too.

"a second of a file with the finder icon"? I don't understand this one.

If nothing helps, reinstall and get your files back from your backup media. (Which of course you _do_ have, right?)
 

granthac

Registered
The finder is never up long enough for me to do anything with it. What I meant was that the the File with a finder icon in it flashes for about 1 second before it goes into it's normal boot up. I am not sure what APE or a HAXIS are. I have back up, I would just rather not go down that road.
-Chris
 

bobw

The Late: SuperMacMod
You can boot into Single User Mode to delete the Finder preferences file.
Run FSCK first;

To run fsck, you first need to start up your Mac in single-user mode. Here's how:

1. Restart your Mac.

2. Immediately press and hold the Command and "S" keys.

You'll see a bunch of text begin scrolling on your screen. In a few more seconds, you'll see the Unix command line prompt (#).

You're now in single-user mode.

Now that you're at the # prompt, here's how to run fsck:

1. Type: "fsck -y" (that's fsck-space-minus-y) (without the quotes)
(If you're running Panther, v 10.3, then type this "fsck -f"

2. Press Return.

The fsck utility will blast some text onto your screen. If there's damage to your disk, you'll see a message that says:

***** FILE SYSTEM WAS MODIFIED *****

If you see this message--and this is extremely important-- repeat running fsck. It is normal to have to run fsck more than once -- the first run's repairs often uncover additional problems..

When fsck finally reports that no problems were found, and the # prompt reappears:

3. After fsck indicates the disk is OK (No problems found), at the prompt, type the following exactly as written:

/sbin/mount -uw /

then press Return. Be sure to note the spaces in this command: there is a space after mount and a space after -uw. This command mounts the file system so you can delete the Finder preferences.

At the prompt, type the following exactly as written:

rm /Users/your_user_name/Library/Preferences/com.apple.finder.plist

where your_user_name is your "short" user name on your computer. Then press Return. The preferences file on your ID are now deleted.


Finally, at the prompt, type reboot and press Return to restart in Mac OS X.
 

granthac

Registered
Okay tried FSCK, funny thing though I have to force check using the -f option (-y does not work) It also says that the Root Device is read only. I am not sure if this is anything or not, but I am completely illiterate when it comes to this end of my Mac. I only had to force run FSCK once though and it said everything was cool. When I tried my user name prompt, it came back telling me that there is "no such file or directory". Any thoughts? Again thanks for the help on this, bobw I appreciate the detailed post. By the way, I still have apple care on this. Should I concede defeat and call them up? I think this way is a bit more fun as I get to do some detective work in an area of my computer I would otherwise not visit. Let me know.
-Chris
 

bobw

The Late: SuperMacMod
Make sure you're using the correct user name. Try both the user name and your short user name.
 

granthac

Registered
No such luck... I still get no such file or directory when I type in the the user name part, even if I do use my short user name.
 

tommy.v

Registered
hi chris

i would recommend repairing the disk using the disk utility from the OS install disk.

* insert the disk
* restart the computer
* hold the option key as soon as u hear the startup sound or jsut keep it pressed as soon as u turn on the computer
* select the install disc
* click installer (10.3) or utilities (10.4) on the top menu bar after selecting english as the main language
* select the disk utility option
* select your MAC HD and then run the disk repair and also the repair disk permissions

Once u finish these try booting to the OS, if that does not work then try the steps below:

* boot to single user mode - hold shift while ur computer is starting
* you should be able to boot to OS in safe mode
* remove the startup items -
- system preferences > accounts > login items
delete all the prgrams that are present
* restart the computer normally - u should be working fine now


Note: If disk repair gives any error then there should be the problem with startup fragmented files on the HD. archive and install os
 

bobw

The Late: SuperMacMod
boot to single user mode - hold shift while ur computer is starting
This won't get you into Single User Mode - Command-S keys will

Shift key - Safe Mode
 

granthac

Registered
I have actually tried all of that stuff... thanks for the help though. Looks like I am headed for an erase and install.
 
Top