mysql access problem on setup(new to unix)

Iolaire

Registered
PS: I got it working by: going to OS 9, searching and delting all sql files on HD, except for those in bb edit and PHP folders, reinstalling and NOT doing this:
mysqladmin -u root password newpassword
For some reason adding the password in this fashion seems to mess things up.

---- link to another LONG thread regarding this ----
People working on this at: http://www.macosx.com/showthread.php?s=&threadid=7560&highlight=ERROR+1045

--- old message --
I set up MySQL by following the dirrections on Mark Liyanage's http://www.entropy.ch/software/macosx/mysql/ however I seem to have some problems..

When I try to say: "sudo mysql" I get this:
[localhost:/usr/local/mysql] iolaire% sudo mysql
ERROR 1045: Access denied for user: 'root@localhost' (Using password: NO)

or
[localhost:/usr/local/mysql] iolaire% mysql -p
Enter password:
ERROR 1045: Access denied for user: 'iolaire@localhost' (Using password: YES)

To set up MySQL I followed these steps:
1 Download and install the package mysql-3.23.43.pkg.tar.gz
2 create a new user in the "Users" System Prefs pane: Name: "MySQL User" Short Name: "mysql"
3 Open a terminal window and type in the following commands:
cd /usr/local/mysql
sudo ./scripts/mysql_install_db
sudo chown -R mysql /usr/local/mysql/*
sudo ./bin/safe_mysqld --user=mysql &
4 mysqladmin -u root password newpassword

I've tried to delte all files with sql in the name via OS 9 and reinstall mysql and follow the instructions, however this did not help.

Please does anyone have a clue what I'm doing wrong? I'd like to get this running so I can learn how to do something with PHP and MySQL, but I've getting blocked during the install!
Thanks,
iolaire
 

NuCleuZ

Registered
Instead of :


[localhost:/usr/local/mysql] iolaire% mysql -p


Have you tried this:

[localhost:/usr/local/mysql] iolaire% mysql -u root -p
 
Top