mysql - does it compile?

stone

Registered
I've downloaded and tried to compile mysql-3.23.36. Configuring goes well then but I get a compiler error a good part into the build when running make.

I've browsed forums and it seems that some people have compiled mysql without any problem at all (an older version).

I would be really grateful to get help in solving this problem.

Thanks!

/stone

# make

(lots of removed output...)

c++ -DMYSQL_SERVER -DDEFAULT_MYSQL_HOME="\"/usr/local\"" -DDATADIR="\"/usr/local/var\"" -DSHAREDIR="\"/usr/local/share/mysql\"" -DHAVE_CONFIG_H -I./../include -I./../regex -I. -I../include -I.. -I. -O3 -DDBUG_OFF -fno-implicit-templates -traditional-cpp -DHAVE_DARWIN_THREADS -traditional-cpp -DHAVE_DARWIN_THREADS -D_P1003_1B_VISIBLE -c mysqld.cc
mysqld.cc: In function `void init_signals()':
mysqld.cc:1241: assignment to `void (*)(int)' from `void (*)()'
make[3]: *** [mysqld.o] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all-recursive-am] Error 2
 

stovak

Registered
------------------------------------------------
Just change line 1232 of sql/mysqld.cc to use:
void (*)(int) rather than void (*)()
------------------------------------------------


Recompile and you should be fine.
I've had it working very nicely for a few days now. The only problem I have is that the mysqladmin shutdown command doesn't seem to work.
stuart.roebuck@adolos.com


Scott Ellsworth <scott@alodar.com>: I can confirm this - the one code change mentioned makes it compilable, but I have not yet had mysqladmin successfully shut it back down.

 

stovak

Registered
Just noticed this fix was for .35 and not .36.

HAS ANYONE COMPILED MYSQL for X.0 ? I can't get mine to compile..... Same error as above....
 

Casey

Registered
i was compiling 3.23.36 when i came across this thread! it errord out as reported and i made the recommended alteration to line 1241. up and running now! what timing!

also... to get msqld up at boot time:
• make a new 'mysql' directory in /System/Library/StartupItems/
• like the readme says, copy /support-files/mysql.server (from the distro) to /System/Library/StartupItems/mysql
• make sure mysql.server is readable and executeable by root
• place <a href="http://www.idiotsyndicate.org/StartupParameters.plist">this file</A> (StartupParameters.plist) in /System/Library/StartupItems/mysql
(option+click that dowload link)

tada!




 
Top