Network drive auto mounting

efoivx

Registered
Has anyone found a way to mount network drives at startup?

I have several shares on a local server machine. The server is running OS 9 the drives are shared via tcp/ip.

I can connect to the server and mount the drive manualy but I have 7 shares, and this becomes a bit of a pain. Is there some way to have them auto mount at startup?

when I run mount from the terminal the shares show up as

afp_07G5ZQ07G5ZQ07G5ZQ07G5ZQ-5 on /Volumes/share1 (nodev, nosuid, mounted by zdx2v8)
afp_07G5ZQ07G5ZQ07G5ZQ07G5ZQ-10 on /Volumes/share2 (nodev, nosuid, mounted by zdx2v8)
afp_07G5ZQ07G5ZQ07G5ZQ07G5ZQ-7 on /Volumes/share3 (nodev, nosuid, mounted by zdx2v8)
afp_07G5ZQ07G5ZQ07G5ZQ07G5ZQ-6 on /Volumes/share4 (nodev, nosuid, mounted by zdx2v8)
afp_07G5ZQ07G5ZQ07G5ZQ07G5ZQ-8 on /Volumes/share5 (nodev, nosuid, mounted by zdx2v8)
afp_07G5ZQ07G5ZQ07G5ZQ07G5ZQ-9 on /Volumes/share6 (nodev, nosuid, mounted by zdx2v8)
afp_07G5ZQ07G5ZQ07G5ZQ07G5ZQ-1 on /Volumes/share7 (nodev, nosuid, mounted by zdx2v8)

Thanks for any help anyone can offer it's appreciated

Cheers
Eddie
 

efoivx

Registered
Anyone? I have searched the forum and apples site and can't seem to find anything.

some way to do it from the unix side must exist.

any clues?
 

efoivx

Registered
While pokin around the sbin I found the command mount_afp

if you type this to the cli you get this

[localhost:~] efo% mount_afp
usage: mount_afp [-o option1[,option2...]]
afp://[username:password]@rhost[:port]/volume node

so I tried

mount_afp afp://[myusername:mypassword]@myserverip/share1

and the result was
mount_afp: No match.

at least this is some progress... maybe someone could expand on this?


cheers
Eddie
 

knighthawk

Registered
I just tried this at work yesterday. We have a Solaris Sun Server that we share 5 drives from. The way we mount them is through Aliases of the drive.

Yesterday when I had OS X loaded (I like writing websites with OmniWeb's source editor), I needed to mount the network drive.

So I double clicked on the alias. The computer gave me an error message saying that the network drive was unable to be found, but it was sitting there mounted ready to be used.

Try that out. It is more effort than what you were looking for (to mount) but a lot less than you currently have.
 

efoivx

Registered
here it is in all it's simple Apple glory.

I was trying so hard to find a way to do it through Networking or through a unix solution but found it in Applescript. The reason this eluded me was that in 9 or older you needed an osax addition to mount afp volumes. It appears it is now included in the basic functions.

mount volume "afp://server ip/sharename" as user name "username" with password "password"

the above line should be on one line in the script editor.

duplicate that line as many times as you need for all your shares. then save the script as an application and set it as a sartup item in the login panel system preferences.

bingo! your drives will mount at startup.

remember to replace

server ip: with your servers ip or I assume you should be able to use the server name as well.

sharename: with the name of the shared item

username: your user name

password: your password


Cheers
Eddie
 
Top