network preferences keep crashing


I've just reinstalled from scratch, and my network preferences won't launch. I get an error message saying the application has unexpectedly quit, the system and other applications have not been affected.

Strange thing is, I'm using the machine to write this post, so ip is working. 9.1 is working fine.
Try launching the Console and then checking your network prefs. The Console may display the answer.

The console I'm refering to displays console messages in the GUI, the app is

and I think the file it checks is:

(the console app isn't the terminal app, thats different)

Post whatever comes up in the console when the net prefs crash on you.
Here's what it says:

retval is 0retval is 0About to send the mach message to loginwindowAug 23 09:22:55 localhost WindowServer[64]: CGXDisableUpdate: Updates disabled by connection 0x3117 for over 1.000000 seconds

2001-08-23 09:30:36.778 ScreenSaverEngine[280] No zero screen
2001-08-23 09:30:37.121 ScreenSaverEngine[281] No zero screen
Event 1
Aug 24 00:53:59 localhost authexec: executing /System/Library/PrivateFrameworks/Installation.framework/Resources/runner

Aug 24 00:55:32 localhost WindowServer[64]: CGXDisableUpdate: Updates disabled by connection 0x3117 for over 1.000000 seconds
Sorry dude, thats really beyond me. Looks like your display server has some issues. Have you tried launching it as a different user? Like:
sudo open '/Applications/System Prefernces'

I really hope someone can help with this. If all fails, just call Apple, they are pretty smart, it just takes *for ever*.
Yes, I tried the unix disk check, and no, it's not 5G24.

Would appear I've developed a weird piece of memory, as OS9 has started crashing on me as well. Memory replaced and everything is fine, apart from my wallet.
Sounds like you may have corrupt network preferences, but the first thing you should do is check you drive for corruption.

I'd still boot into single user mode holding down and type "fsck -y" to run Disk First Aid to make sure that everything is still okay on your disk.

Next create a new user using a different short name and try opening your Network prefs. I suspect the problem is related to corrupt user prefs. The question I have for you, is were you using the screen saver option previously? Creating a new user would circumvent those prefs anyway. Try the new user route.

By reading your post, it appears you simply re-installed over the old OS. If you did, your old user prefs would be left unchanged and the problem would still exist.

Hope this helps.
I'll add in that the file the Network Preferences portion uses <i>isn't</i> in your user/Library/Preferences ...this is a global setting and is stored somewhere else.

Luckily I found where else :D

You can move/delete the file in /private/var/db/SystemConfiguration/preferences.xml (you'll need to be root to delete it). Once you move this file or delete it, the Network preferences portion of System Preferences will be totally blank - you'll have to refill in all the info you previously had there.

I'd suggest moving the file rather than deleting it, since I haven't actually checked to see if it creates a new preferences.xml file.