Network Time can't reach server

MIS Lady

Every time I put in a network time server, nothing happens. I put in, I put in our local time server. I put the IP address of both. I finally opened the console log to watch what was going on and each time it said "no suitable server for synchronization found".

All other networking working fine.

Anyone have any ideas on this?

PB G3 Bronze
128 M RAM
Yes Port 123 is open. We are able to set network time with our machines in 9.1 to but not with those in OS X.

And I am the network administrator ;)
Hi MIS Lady. Can we assume you are using the manual configuration? Or are you venturing this with NetInfo?
Also, it would help if you gave some specifics of your machine and network config.
Hi Klink, Yes this is via the manual config. I also tried using the ntpdate command in the terminal with the same result.

So far we have had the problem with the Powerbook g3 (Bronze) and a powermac G4 400. both are running 10.0.4 Build 4Q12 (These are our only OS X machines)

Both have static IP addresses on our network. Our gateway is a Windows 2000 box. Our router is a Cisco 3500.

We also have an internal Unix box that can be used as a network time server. Some of our 9.1 machines use it with no problem. But it gets the same error "no suitable server for synchronization found" when you enter it manually it the network time in OS X.

Also if I boot either of the problem machines to 9.1 it will synch with no problem.
I'm making an educated guess here, but I think there are other daemons and protocols at work in regards to time synchronization with the Date & Time applet in System Preferences. A trip through NetInfo disclosed other 'time' like services such as; daytime (tcp/udp 13), time (tcp/udp 37), and timed (udp 525). A rather easy way to see if this is an issue is to place, say the Bronze PB, outside your local network, unobstructed and naked on the internet (sans firewalls/filters), and attempt time sync. At least this can tell you if it's a protocol/config issue with your X machs or your Win2k/Cisco gateway/router.

I have my time sync working correctly on a Bronze with 10.0.4 Build 4Q12, with NetInfo or the Manual entry. The diff being my network is wide open (home aDSL). So this should be a doable thing for you.
Just to clarify something. I was lead into NetInfo because I noticed if I turned on Manual time sync with Date & Time, it would create an ntp directory entry in NetInfo, hence my suspicion that NetInfo was involved regardless if one used Manual or NetInfo for time sync. Kind of goes in concert with anything network in X, apparently.

I'm also under the impression that ntp not only uses tcp port 123 but udp 123 as well. I'm not familiar with the LynkSys routers or there logging features and perhaps udp connects would not show in your log readings. Just a thought. But I agree with you as you agree with me, one should reduce peripheral complexity and control the test bed.

Yes, please let us know the outcome. This is getting even more interesting.
I took the PowerBook next door to check it on another network and that worked OK, so I went and delved deeper into the router to find the issue. Turns out the problem was with our exterior router and I had been checking the interior router. (We go through a co-lo)

We had all the udp ports implicitly open as part of an any any permit statement, so it was assumed that UDP 123 was open. I went in and explicitly opened UDP 123 and that cleared it all up. Very strange.

I'm not sure how 9.1 made it through before. And OS X still will not synch with our internal time server, although 9.1 will. So the mystery continues

Thanks to both of you for helping hash this out.