Networking: Ethernet & PPP?

fryke

Moderator
Staff member
Mod
Hmm... So I've set my iBook up and it works on Ethernet. I have a static IP and everything. Now I go home and want to use my internal modem. PPP connects fine - but the computer does not *USE* the PPP connection. To what do I have to set the networking control pane so it works?

Fryke.
 

marc

Registered
Hi the solution to you problem isn't in the network controll panel, what you need is PPP Connect which is in the Apps folder, I think I may have moved mine. Open it enter your isp details there and then connect to the internet by clicking connect, OS X dosen't seem to support auto connecting using the modem yet. This way you don't need to chainge any settings at all to switch from eathernet to modem.

Hope this is enough info and that it helps

Marc
 

fryke

Moderator
Staff member
Mod
Hmm... That doesn't really help me. All applications still want to use Ethernet, even when PPP is up and running a connection. That - of course - *was* my question the first time.

Fryke.
 

fryke

Moderator
Staff member
Mod
Hmm... That doesn't really help me. All applications still want to use Ethernet, even when PPP is up and running a connection. That - of course - *was* my question the first time.

Fryke.
 

marc

Registered
Hello
Yes sorry having re read your post I see that I got it wrong sorry. I'm curious though because it is working fine for me, I'm even using natd to turn my g4 into a gateway and everything is clicking over fine. I've looked at my network setup panel and the only thing I can see in my setup that may be different to yours is that the configure dns is set to automatic. Could this make a difference? Also what indicates that the system is trying to use Ethernet not ppp? Although apple does say in the docs about ppp that the network panel should be turned off due to incompatiblity issues I've not encountered these.
Hope this is more useful then the last one

Marc
 

sCreeD

Registered
Ran into this early on with my iBook. I installed PB at work connected to the LAN. Went home and used PPP connect fine, except I couldn't make a connection to our web server (same subnet as workstations).

Long story short, because I still had the Ethernet configured to be connected to the LAN, I couldn't access anything in the subnet through PPP. (At first I had a panic-attack thinking our router was down or something)!

So Ethernet and PPP configs have a conflict.

I changed TCP/IP to "No Connection."

What OS X needs is a Location Manager!!!


Screed
 

stizz

gorilla beta tester
I had a similar problem. I installed OSX on my Pismo at work and then when I went home and tried to use PPP,...

what I discovered was this.
To use PPP, set your network control panel to "no connection" then RESTART

if you dont restart, ppp wont work .
Then when you go back to work and connect via ethernet, make sure you restart after making changes to the network control panel.

STizz
 
Top