Networking PC <> Mac -- Strange behavior

Liselle

Registered
Hello folks, switcher here (well, sort of). I picked up a shiny new Mac Mini last week, and I've been having limited success trying to get it to talk to my PC. A quick history:

Both machines are hooked up to a switch. The switch is connected to a hub, which the cable modem and a third PC are plugged into. All of the machines in question have "real" IP addresses, there is no router in this setup (pardon if I mess up any terminology, I'm a networking newbie). I've tried following all manner of FAQ and guide to get them talking to each other, but to no avail. Always the the Mac would time our, error 36, when trying to connect. So, I gave up on that route, nobody could really help me. :(

Well, I have a FireWire card in the PC for my iPod, so I picked up a 6-to-6 Firewire cable, and connected both machines that way. That was a little more promising: both the machines could see my iPod, and the Windows box detected some unknown device on the other end. Windows Sharing was already set up from the previous attempt, so I flipped over to the Mac, opened Prefs, and assigned an IP address of 192.0.0.1 to the Firefire connection. I have no idea what a subnet is, but I plugged in 255.255.255.0 and the Mac seemed to be happy with that. I did the same thing in Windows, except with an IP address of 192.0.0.2.

Browsing to the Mac Mini in Network Neighborhood looks like it worked. I had nothing in there, but I could poke around in my home directory. I don't much care from connecting to the Mac from Windows, but it was a nice bonus, anyway.

Now on the Mac, I did a Connect to Server in Finder, and plugged in smb://192.0.0.2 or somesuch. Eureka! It prompted me for a password (workgroup and username already filled in, I am not complaining there), then the share name, and I was in... sort of.

The "sort of" is why I am here, asking for help. The first share was just a folder named "Test", with a text file containing "You are teh winnar!!", which I was successfully able to open. The next share... failed. It's a folder with about 127 or so pictures, JPGs, GIFs, BMPs, you name it. Trying to connect would give me a spinning beachball and not much else. Inspired by my near-success, I attempted to find the cause of the problem.

Nesting the folder into the first test share equalled the same beachball death. Pulling out the pictures and putting them into the test folder one-by-one worked for a while... until I hit 60 total, and then it crapped the bed. 59 would work, and 60 would kill it.

Then I tried it with empty text files. As before, it would get to the certain number, and then Finder would die. In this case, it was 49 docs or so.. the 50th would be the killing blow.

I connected to a share that had movies and music and stuff, over 20 gigs worth: no problem. There were about 8 folders in the base directory, each with 20-30 files. I was able to play those movies and music files on the Mac, (MPLAYER), which made me very happy. So, I guess it's not a filesize issue?

Anyway, I searched everywhere for the answer, to no avail. I'm not even sure if I was looking in the right places. So anyway, if anyone has any advice, I'd sure love to hear it. I have rudimentary sharing now, so that's kind of cool, but I would like to be able to share folders to my Mac without having to count files before I connect.

Mac Mini is running 10.4.1, Windows machine is XP pro. I can list out the steps that I took for configuration, but it would be even longer than the description up above (I've been working at this tirelessly for some time now).

Much appreciation for any help or links you can provide. Thank you. :)
 

helium_teapot

Registered
have you tried accessing it like this
smb://username:password@server.domain/
eg: smb://Stephen@MR-KOOL.mshome.net/ (where Stephen is the user and MR-KOOL is the name of the machine)
there's heaps of info at http://www.macwindows.com/panther.html about doing all this but it panther not tiger (can't imagine it's that different)
 

Liselle

Registered
Yes, that works. As I said, I don't have trouble opening the connection unless there are more than 50 or 60 files in the share I'm trying to connect to. It really bugs me that I can't figure out why.
 
Top