New HP Laserjet 2420 - printing crashes in all apps

soxsoxsox

Registered
Hello -

I recently purchased an HP Laserjet 2420 printer, and have tried to get it working without success. I'm using OS 10.3.9 with a USB cable. I can print only my e-mails in Microsoft Entourage, but every other application I've tried it with has resulted in the same crash (see snippet below from crash report)

Date/Time: 2005-06-25 12:48:35 -0500
OS Version: 10.3.9 (Build 7W98)
Report Version: 2

Command: TextEdit
Path: /Applications/TextEdit.app/Contents/MacOS/TextEdit
Version: 1.3 (202)
PID: 485
Thread: 0

Exception: EXC_BAD_ACCESS (0x0001)
Codes: KERN_PROTECTION_FAILURE (0x0002) at 0x00000000

Thread 0 Crashed:
0 com.hp.framework.imaging 0x00f01c14 GetItemsCount__13AControlGroup + 0x20
1 com.hp.print.pde.HPFinishing 0x00f502c4 Initialize + 0x820
2 ...apple.print.framework.Print 0x91925954

<snip>
I've tried a variety of things to fix the problem -- trashing printer preferences, using the fixamac printing utility, installing new gimp-print driver, fixing permissions, etc. Nothing works. I also created a new user account and tried to print from that account with the same result.

I've searched extensively on the internet for answers, and can't find anyone else with a similar problem, so I'm hoping someone here knows how I could further diagnose my issue. HP's support is M-F and I really need to get this thing working ASAP.

Thanks.
 

soxsoxsox

Registered
I figured it out based on a post at Gimp-print forum.

All I did was delete the printer using the Printer Setup Utility, unplug it from the power cord, plug it back in and let the computer automatically recognize the printer, which it did. The "kind" in the printer description now says "generic Postscript printer" instead of the model #, but whatever, I can print from every application.

Phew.
 

bleichenbacher

Registered
Had a very similar problem:

Installation of the printer driver on various Apple G3s and G4s in a network (LAN, printing with AppleTalk) worked fine, the printer was recognized properly. But all applications (browsers, ms office products) crashed instead of displaying the print dialog.

Printing from any application to a different printer (e. g. LJ 2300) and then switching back to the 2420n without quitting the application would work as well, but that was of course not a solution.

The 2420 printer driver would also work on a Powerbook with OS X 10.4.2.

I had to switch back to generic printer manually on all machines with OS X 10.3.7 to get the printing working.

Thanx for your comment, saved me quite some time.

Michael
 
Top