New Safari twist


I'm hoping there is a setting to change this back... I updated to 10.14.4 and now I have to touch the touch-id to get Safari to use the passwords that it has stored away. There appears to be some web sites where that isn't the case.

I have the check box checked in Safari => Preferences => AutoFill => User names and passwords as well as the similar check box under Safari => Preferences => Passwords.

Has anyone else hit this?


Google is your friend (sometimes) Apple => System Preferences => Touch ID => Safari AutoFill (uncheck it to get the old behavior)

I wonder how many folks prefer the new to the old. My guess is its the same percentage that use the native keyboard instead of a detached keyboard. :)


Rosie Moderator
Staff member
I couldn't use Touch ID. My guess is not too many people would be able to use the 'new feature'.