NFS and 10.4 driving me mad

khalidschofield

Registered
Hi
getting NFS to mount under OS10.4 is driving me nuts.

I can't for the life in me get my dusl G5 to mount my nfs servers exports.

My nfs server is running irix 6.5.26F and has exports. It's not the
security on my nfs server it's OS 10.4 thats the pain.

when running mount_nfs on OS 10

[root@G5 /var/log]mount_nfs 192.168.0.2:/disk1 /disk1

I get this error

mount_nfs: can't access /disk1: Permission denied

even if I do chmod 777 /disk1 the local file system I get the same error
so it's not a local permissions issue either.

I really have no clue what's going on.

I've even tried entering data into /etc/fstab as the netinfo database
should look at this too.

On boot (I've set it to boot verbosly) it complains fstab in wrong format

here is /etc/fstab

[root@G5 /var/log]cat /etc/fstab
192.168.0.2:/disk1 /Network/Servers nfs resvport,net 0
0
192.168.0.2:/disk2 /Network/Servers nfs resvport,net 0
0
192.168.0.2:/disk3 /Network/Servers nfs resvport,net 0
0
192.168.0.2:/disk4 /Network/Servers nfs resvport,net 0
0
192.168.0.2:/disk5 /Network/Servers nfs resvport,net 0
0
192.168.0.2:/disk6 /Network/Servers nfs resvport,net 0
0
192.168.0.2:/disk7 /Network/Servers nfs resvport,net 0
0

I don't get it

I really want to mount 192.168.0.2:/disk1 as /disk1 on my local system to be honest in an ideal world.


please help I need my raid to mount over nfs..

thanks
 

jween

Registered
could this be a version problem? I just upgraded from 10.3 to 10.4.2 and lost connectivity with my Linux RH9 nfs server. "name/password" error, which I think is the same as yours, only I used the finder and not commandline. I've had no luck so far in resolving the issue (except using ftp to get at my files). "nfs-manager" doesn't help either. So, I guess it's either figure out how to get the osx client (v4 I think) to recognize whatever version the server is running (v3 I suppose) or upgrade the server.
 

jween

Registered
Upgrading to the recent 10.4.3 did not help either. smb networking was tinkered with, but apparently not nfs.

Jon
 
Top