nfs mounting a directory

holmBrew

Official Volunteer
:confused:

how do i mount an nfs directory?

is it done with through the NetInfo Manager? or is it easier to do it on the CLI?

will it work if my machine is on a different subnet than the machine that serves nfs?

-jeh-
 

howardm4

Registered
You can do via command line easy enough or use NFSManager which is a d/l'ble shareware
item.

if you dont want to get too fancy, you can:

mount -t nfs host:/exported/partition /mnt/somename

mnt and somename have to pre-exist before you call mount (sudo).

You can also automount it if your adventurous.
 

holmBrew

Official Volunteer
i tried:

mount -t nfs host:~user/ .

and got this---> NFS Portmap: RPC: Program not registered
 

howardm4

Registered
Are you sure mountd is running on the other machine?

Check w/ the rpcinfo & showmount commands.
 

holmBrew

Official Volunteer
i figured it out...it turns out the that the machine serving nfs was not set up to serve to the subnet that my mac is one...i had the entry changed, and it worked great.

it is very nice to be able to edit files locally and not have to mess around with endless scp's

thanks for the help!

:D
 

holmBrew

Official Volunteer
try putting the moint point to:

/User/username/Desktop/anyName/

or to

/Volumes/anyName/

i.e.

mount -t nfs server:/path /User/username/Desktop/anyName/

anyName with look like another Volume in the GUI, but like a directory in the CLI

-Jason
 

mheimann

Registered
thanks - now the mount point appears on the desktop. However, I cannot access the contents of the mounted directory from classic applications. Is this in principle not possible or is there a workaround?
 

holmBrew

Official Volunteer
directly accessing files in a mounted directory with a Classic application is something that i have not been able to do either. the way i have been getting around it is copying the file(s) i need to edit w/a Classic app to my Desktop and then doing the work from there....

it is kind of kludgey to have to do it that way, but it works.

i have had similar problems with trying to access removeable media from Classic apps( ie. Zip disks)...

-Jason
 
Top