No audio on .m4v files after I encoded them!

absolutelypb

Registered
Hello,

I recently downloaded some videos onto my MacBook Pro (running Lion) from an SD card. The videos would not play on my mac, but they played (with audio) on a PC, so I right clicked on the videos and encoded them so they would play. After that, they played, but there was no audio. I don't know anything about codecs, but I'm guessing I'm missing an audio one? If anyone could help me out it would be great! I also have the MediaInfo screenshot of one of the videos..


eneral / Container Stream #1
Total Video Streams for this File.................1
Video Codecs Used.................................AVC
File Format.......................................MPEG-4
Play Time.........................................28s 528ms
Total File Size...................................5.15 MiB
Total Stream BitRate..............................1 515 Kbps
Encoded with......................................Mac OS X v10.7.4 (CMA 891, CM 705.78, x86_64)
Video Stream #1
Codec (Human Name)................................AVC
Codec (FourCC)....................................avc1
Codec Profile.....................................Baseline@L3.0
Frame Width.......................................640 pixels
Frame Height......................................352 pixels
Frame Rate........................................29.970 fps
Total Frames......................................855
Display Aspect Ratio..............................16:9
Scan Type.........................................Progressive
Color Space.......................................YUV
Codec Settings (Summary)..........................1 Ref Frames
QF (like Gordian Knot)............................0.224
Codec Settings (CABAC)............................No
Codec Settings (Reference Frames).................1
Video Stream Length...............................28s 528ms
Video Stream BitRate..............................1 513 Kbps
Video Stream BitRate Mode.........................VBR
Bit Depth.........................................8 bits
Video Stream Size.................................5.14 MiB (100%)
Video Stream Title................................Core Media Video
Date of Original Encoding.........................UTC 2012-07-01 06:44:51
Color Primaries...................................BT.601-6 525, BT.1358 525, BT.1700 NTSC, SMPTE 170M
Transfer Characteristics..........................BT.709-5, BT.1361
Matrix Coefficients...............................BT.601-6 525, BT.1358 525, BT.1700 NTSC, SMPTE 170M
 

MisterMe

Registered
The specs that you posted indicate that your video is 28 seconds of 640x352 video. It sounds an awful lot like you downloaded the preview and not the actual video.
 
Top