No FTP access without using the terminal


Hi All,

I hope somebody can offer some suggestions to what should be a straightforward situation - I can't get access to public FTP sites through any of my normal applications (including web browsers) but I can get access through the terminal.

I had this problem before (and briefly fixed it, though it's messed up again now) that either fails to log-in correctly or just sits and time-outs. I've checked the System Preferences for anything that might be stopping the connections but can't fix the problem. I'm using 10.2.8 and have disabled the FireWall and tried changing the passive-mode setting to no avail. Some applications that I normally use include iGetter, Fetch, Transmit and the site upload feature in Dreamweaver MX - in fact, anything other than the terminal - help! Of course, maybe I should just learn to embrace that hardcore-coding feel you get entering FTP commands... :D


The only thing I would suspect would be proxy settings, as I'm not sure if these are applied to the Terminal's FTP client, but almost certainly are applied to all GUI FTP clients. So, I'd start by looking at the proxy settings first.
symphonix - thanks for the suggestion...

I think the problem is to do with the way my applications set passive (PASV) mode (or not) - I downloaded a copy of Transmit 2.6.2 and this seems to work fine. This therefore leads me to the conclusion that

1) network connections do not work correctly under Classic Support (all my proper FTP applications were Classic, with passive mode selected in the prefs)

2) my OS X browsers (all five of them, and I haven't even got FireFox yet) obviously don't handle FTP transactions very well

Also, when I connected to the Newtek FTP site (makers of Lightwave) at a message advising me that I should use passive mode kept coming up after every command I entered even though the login message confirmed that I had connected in passive mode, which was activated in the System Preferences.

Hmm...solved now anyway - for the moment ;)