No ignore dial tone available?

Onslow

Registered
Australian telecom has a unique dial tone and I have always needed to ignore dial tone to get PPP to connect.
OSX pb appears to not have this option, so I am stuck with no internet..Any suggestions?
 

chimi

Registered
The same applies to Italian telecom. On the other side, I have this problem on my old iMac rev. B, while with the new slot-loading iMac PPP-connect just works fine. I suppose there is a problem connected to the different internal modem, different default script or even both.

Francesco
 

cmh

Registered
yer i am experiencing the same problem...no dial tone no connection under osx but even without selecting the 'ignore dial-tone' option under os9 i can connect fine

if i cannot connect to the net under osx this is going to suck bigtime!

someone must have a suggestion?
 

oliverw

Registered
same here.
I am on a PowerBook, any different from a desktop (modem scripts etc) - The PB modem seems much worse than the Desktop one.
Connects great through the network at work!

I posted about this last week and got no replies so... Looks like we will have to watch wait and see. We can't be the only ones who are having this problem.

Anyone got a CLI command to get around it?

cheers,
o
 

Onslow

Registered
I am on the net at last. PPP connect has no option to ignore dial tone so I found how to get into the script and change it.

1. in Text edit open etc/ppp/modems
2. choose the modem you wish to hack.and open it
3. change the x4 to x3 in the string and comment out with the # the Error No Dial tone line.

Helped me hope it helps someone else.
 

chimi

Registered
I found a slightly different workaround, which works fine with italian telecom.
To use it, copy the following script to a text file named, e.g., AppleChimi, then copy it to directory /etc/ppp/modems with the terminal command:

cp AppleChimi /etc/ppp/modems/AppleChimi

then open PPP Connect and choose AppleChimi.



# AppleChimi: X PPP workaround
#----------------------------------------------------------#
# Modem = "Apple Internal Modem 56k" #
# #
# Use AT commands to contact the Apple Internal #
# 56 K modem #
# #
# Version = 1.0 #
# Date = 04/14/2000 #
# #
# Author = #
#----------------------------------------------------------#

# define ABORT keywords
ABORT "ERROR"
ABORT "BUSY"
ABORT "NO CARRIER"
ABORT "NO DIALTONE"

# delay for 3 seconds
# gives time to the modem to power on
"" "\d\d\d"

# send init string
# Original versione
#"" "AT&FE0W1Q0V1X4&C1&K3S95=1&D3S7=75S0=0"
# Modified: ignore dial tone
"" "AT&FE0W1Q0V1X4&C1&K3S95=1&D3S7=75S0=0X1S6=4"
OK ""

# increase timeout for connection
TIMEOUT 75

# send dial command
"" "ATD \T"
CONNECT ""

# perform extra work if necessary
# like login/password sequence
# ...


# script is finished !
 

chimi

Registered
P.S.: sorry, I forgot to say that you will probably need to use superuser account, command "su" on Terminal
 
Top