No printers work anymore

gumse

Member
I get a strange phenomena when I try to print. I have a Ethernet-LaserJet and a USB-DeskJet. They have both worked ok before.

But today when i try to print i get the "Preparing" dialog and then after 0.5 seconds i get a dialog saying "Error while printing".

I have restarted the computer, removed and added the printers to the print center several times, but nothing helps.

I get no further explanations of the error, in the console it says:
"2002-09-16 11:54:17.707 TextEdit[595] PMSessionBeginDocumentNoDialog failed (error code = -108)"

Anyone ????? Please !!!!!
 

Squintel

Registered
I have a problem printing with an HP OfficeJet and contacted HP. They informed me that while their printer drivers worked in 10.1.5, they no longer work in 10.2. They offered no specific date as to when they would have an update available on the web. The technical support person actually said the drivers would likely be available within "the next couple of months."
 

gumse

Member
I have drivers for my printers and they worked in 10.2 yesterday , so this is probably another issue.
I have tried "Repair disk Permissions" in Disk Utility , I have deleted /var/spool/printing and /var/spool/printers , no luck so far.
 

gumse

Member
As lined out in AppleCare Document 106726 I deleted /Library/Printers. Then i tried to install the drivers from the 10.2 CD , but it "Unexpectedly quit" all the time.
Then i copied /Library/Printers from another (working) Mac. Then i'm back to square one, I can add my printers ok, it correctly identifies the printer type, but when I print I get the sam "Print Error" as before....
 

gumse

Member
After re-installing 10.2 from the CD's , printing is now ok again, really can't say what the original problem was though.
 
Top