No Right-click Contextual Menu After 10.4.2 Update


I updated from Tiger 10.4.1 to 10.4.2. Now when I Right-Click my mouse, or do a Control-click on my keyboard, I get a long pause with the rotating beach ball, then all the icons on the desktop and any open windows disappear for a moment. Then the icons and windows return, plus some windows I'd recently closed now reappear. The Contextual Menu never appears.

I ran Disk Utility and MacJanitor. Plus restarted without any Login items. Nothing seems to help this problem.

I have a Ti Powerbook.

Any help would be appreciated.



Hi there - It appears that I have the identical issue - is anybody aware of the solution to this issue or the specific cause of these symptoms?

Thanks :)



The problem exists for 10.4.3 as well. I just upgraded from 10.3.9 to 10.4.3 on a 15" Powerbook. The right-click or control-click for contextual menus in the Finder causes a Finder crash and restart. Right-click works in other places, including: dock items, Illustrator.


Others have reported a problem with Stuffit Expander version 10 causing this behavior. Evidently it installs a buggy contextual menu item. See:

On my system, I removed the file "StuffitCM.plugin" from the folder "/Library/Contextual Menu Items" and rebooted. Now my contextual menus work again. I tried just the Stuffit Expander app on an archive and it seemed to work fine.