Noo-B Need help with D2:LOD on wifes G4 !

Kent_S_S

Registered
Okay, I'm an old PC user. I've had D2:LOD and played it to death on my old PC. Seeking better smoother performance I'm trying to play it on my wifes G4 which is running 10.2.8.

When I tried to install LOD under OS X, it started up classic mode. Not wanting to have to go through the 'translator' I just stopped, booted into 9.2.2 and installed LOD there.

The game plays fine in 9.2.2 but lags a little. Now, I see that there's an OS X installer downloadable from Blizzard. Does that enable me to play LOD under OS X instead of running it in Classic mode?

If so, is it just that one single update/package that needs to be applied?

Also, will my character under 9.2.2 be effected?

Not sure if it matters, but on the expansion (LOD) CD it states that it is version 1.07.

Thanks for the direction.
 

HateEternal

Mac Metal Head
The OSX build should allow you to play it natively on X, usually with these sort of things the engine is recompiled but maps and other are still used from the original.

Might want to make a backup anyways.
 

Damrod

Registered
Kent_S_S said:
Okay, I'm an old PC user. I've had D2:LOD and played it to death on my old PC. Seeking better smoother performance I'm trying to play it on my wifes G4 which is running 10.2.8.

When I tried to install LOD under OS X, it started up classic mode. Not wanting to have to go through the 'translator' I just stopped, booted into 9.2.2 and installed LOD there.

The game plays fine in 9.2.2 but lags a little. Now, I see that there's an OS X installer downloadable from Blizzard. Does that enable me to play LOD under OS X instead of running it in Classic mode?

If so, is it just that one single update/package that needs to be applied?

Also, will my character under 9.2.2 be effected?

Not sure if it matters, but on the expansion (LOD) CD it states that it is version 1.07.

Thanks for the direction.
The OS X version just packs a different executable, and a couple of additional game librarys. the original game files are kept the same. It should make no problems at all.

But a small backup of your characters never hurts. ;)
 

Kent_S_S

Registered
Great. I guess I'll DL the file then. But which file is it?

The patch:
- Diablo_II_LoD_1.10b_Patch(Carbon).sit.bin
or
- 'Native Installer' Diablo_II_Installer.dmg ?

Since I'm on dial-up, I'm hoping it's not both...


By the way, I have the space to just copy the D2 folder to another drive. I understand that on a MAC, moving program files around like that is less of an issue than with a PC. Will the game be effected at all if I move the game folder to a different drive and run it from there?
 

HateEternal

Mac Metal Head
I think you need the native installer. But you might end up needing both.

It shouldn't make a difference where the game saves are stored. You just need to find the right folder to get them from.
 

MBHockey

Registered
You'd need the native installer unless your wifes G4 has Classic installed.

Blizzard did this with Starcraft, too.

If you don't have classic, you probably need to:

1) download the native installer
2) then patch your version to the latest
 

Kent_S_S

Registered
Well, I already have the program installed. If by native installer, they're referring to classic mode launching when I install it, then I think I'm okay. When I saw Classic Mode come up I just closed it and installed LOD under OS 9.2.2 instead.

So, with it already installed, do you guys think if I install the OS X patch as it sits would it run in OS X?

The documentation on this on the Blizzard site is pathetic. Glad I can get some decent advice from this forum.
 

Kent_S_S

Registered
I hope you're right, but the character files are easy enough to copy off somewhere if I botch the job.

BTW, I finally got the 'official' word back from Blizzard:

Hello Kent,

You're going to need to uninstall the version that's running in Classic Mode. Once that's done re-install the game with the native installer in OS X and it should run under OS X without needing Classic Mode.

Sincerely,

Justin K.
Blizzard Entertainment
Technical Support Representative


Customer satisfaction is a top priority here at Blizzard Entertainment, and we would like your feedback on the level of service you have received. Please feel free to provide such feedback at the following web address: http://www.blizzard.com/support/?id=eSurvey000&i=301&d=6/6/2005 9:31:15 AM&t=me@myprovider.com

-----Original Message-----
From: me@myprovider.com
To: justink.support at blizzard.com
Sent: 6/3/2005 8:19:52 PM
Subject: Re: Diablo II: Lord of Destruction - Install/Uninstall Issues

Dude! You did not answer my questions - you just replied with the same thing you sent the first time.

1. Does downloading and using the OS X installer for Diablo2:LOD enable the game to run in OS X without needing Classic mode?

2. If so, do I need to remove the current installation of LOD that was installed under 9.2.2?

Thank you for your help. -ME
So, there you have it. I'm going to try running the OS X patch on my version of the program installed under 9.2.2

Wish me luck. :eek:
 

Kent_S_S

Registered
Worked perfectly.

So, to confirm - I played D2:LOD for 2 hours last night after performing the OS X update.

To Summarize:

1. I installed D2:LOD under 9.2.2 on the G4.
2. Played game for a while and noticed poor performance.
3. DL'd and installed the 1.10b OS X update for LOD (against the advice of the Blizzard Support staff).
4. Played D2:LOD(Carbon) last night in OS X successfully and noticed SIGNIFICANT performance improvement.

Thanks for the help folks. Happy gaming!
 
Top