Not enough privileges-I'm the admin!?!

Soprano

Registered
Ok, I'm stumped on this one. I just tried playing Sims and upon launching, it states it can't launch, as it can't access to the userdata folder (read/write) because I don't have enough privileges. I just played this a week or so ago! Nothing has been changed in the system. I am logged in as admin, and also my apps are on a seperate partition. I even tried logging in as root, still same error. I selected the disk and turned off privileges for that drive and that didn't work either. I tried Super Get Info, and it shows I have read/write access to those folders. What the hell am I to do? Is there a Unix command I can use in the Terminal? I am able to trash files in that drive and create folders without problems-just can't run Sims.....Thanks in advance.
 

tony

gamelaner
Not just 'read'. On UNIX, you must also have 'execute' permission on the enclosing folders.
 

ulrik

Registered
Best way at the moment (seems to be fixed with 10.1 as far as I can tell):

Fire up Netinfo Manager, selects Users, select Root, delete the password, save the setting, login as root and try it again.

Worked for me often, allthough I also had files even the root was unable to affect.
 

ulrik

Registered
damnit, just realised that you already logged in as root....well then.....uhm......call apple
 

Peggan

Registered
Hi I dunno if this works but you can try it if you like.
in the terminal try going to your user data folder.
Then write
sudo chmod -R 666 *

this will give you read write access for all users. from this directory and all the sub directories and files.
 

Edward

Registered
This used to happen to me a lot.

What I did to work around this issue was to make another user with "Admin" rights. So whenever it asked for an admin password, I'd use the new user's one and it got me through.

Unfortunately, this is a workaround and not a fix.
 

FireWire

Registered
This may not be the answer for this problem, but it has saved me a few times.

Find the File that wont delete and check to see if it is locked. To do so:

1. Click on the file.
2. Under the "File" menu select "Get Info" (or press command I)
3. Make sure the "Locked" checkbox is not selected.

Tim
=-=-=-=-=-=-=-=-=-=-=-=-=-=
http://www.saltedwound.com
 
Top