Odd Anacron error message

TommyWillB

Registered
A very long time ago I installed Anacron and configured it to do the regular hourly/daily/montly cleanup work.

Just this week something odd started happening. I have a password protected disk image that I periodically mount. It seems this was mounted when Anacron started it's cleanup work.

At that time it gave me an error message, and it continues to do so every day even through I have dismounted the disk image. Here is the message (they come as emails from root):
root@localhost said:
/sw/etc/cron.daily/findutils:
find: /Volumes/<my disk image>: Input/output error
How do I get Anacron to "forget" about this disk image and not continually try to do its cleanup work on it?
 

TommyWillB

Registered
Hmmm.... Is there some sort of monitary reward for stumping the entire MacOSX.com community?

So, I'm not sure what happened, but I'll explain what I've done to get around it..

Aparently the last time I dismounted the disk image Anacron was complaining about, it did not dismount properly. It was gone from the Finder and command line, including in the /Volumes folder... but it still showed up as a mounted "ghost" in Disk Utility.

Trying to dismount/eject it from Disk Utility continually gave the same error Anacron reports. I then logged out and tried it again logged in and running Disk Utility as root... Same deal... no luck.

Oddly I was able to make a Finder copy of the .dmg file that mounted/dismouted fine.

So I rebooted, and then the disk image seemed to be back to its good state. I ran First Aid in Disk Utilities, and it found no problem.

Odd...

Truely odd...


(I don't like random mysteries... The drive me friggin nuts and make me worry about my machine...)
 
Top