Official: High Sierra Issues

Discussion in 'Mac OS X System & Mac Software' started by Cheryl, Oct 26, 2017.

  1. Cheryl

    Cheryl
    uix_expand uix_collapse
    Rosie Moderator
    Staff Member Mod

    Joined:
    Dec 26, 2001
    Messages:
    4,408
    Likes Received:
    86
    Here’s where to post issues, problems, rants about High Sierra
     
  2. Doctor X

    Doctor X
    uix_expand uix_collapse
    Registered

    Joined:
    Nov 21, 2007
    Messages:
    1,572
    Likes Received:
    21
    Hybrid SSD, High Sierra, and You!

    By Way of an Introduction:
    This reconstructs a post I made a few months ago when I tried to upgrade to High Sierra. Bottom line is despite my computer being compatible, App Store would not detect the need to update, and when I did update, halfway through, I would get this message:

    Worse, at that stage, the computer proved no longer bootable--I would even get t3h d34dly Kernal Panics!!11!

    [​IMG]

    Why this was, we could not discern. "You should wait for a few updates, why not?" After some repeat messes, some research, we move on to what I discover'd:

    • 1. High Sierra is designed for the now standard Solid State Drives ["SSD"--Ed.]
      2. Apple mumbles a few things about it being incompatible with Hybrid-SSDs, maybe, we think, you should buy a new Macbook Pro, why not?
      3. "We plan to address this . . . soon. . . ."
      4. Sod off . . . fat pig!

    I also discovered some interesting links at osxdaily which you should visit, why not? Specifically, to create a bootable Instalation Disk [USB or SD--Ed.]. I also learned that you can load on to the non-new architecture. You can supposedly force it to not upgrade.

    Leave aside concern about APFS. The problem is that direct upgrade quite literally puts thing--like parts of your system--in the wrong place--duplicating applications, yadda, yadda.

    How To Do it on the Hybrid-SSD:

    1. Clone Your Drive:
    DO it! Seriously. Trust me. Much easier to recover from a clone. Especially given one of the steps following.

    2. Create the Installation Disk: Given the next step and the failure to upgrade "in place," you should do this. See the osxdaily links for a very simple way to make such a disk. Remember all that advice about problems updating your OS over Al Gore's Interwebs? This is a bigger problem with the Hybrid-SSD.

    3. Boot to Installation Disk: this allows you to run Disk Utility.

    4. Erase Your Disk and Format as APFS:
    it took a few tries to fully erase--it would stop and state there was an error. However, if you then Repair the disk it will erase it. I know . . . I had to do this process a few times due to stupidity.

    5. Install High Sierra and Make Some Coffee: Start binge-watching the Australian series Rake. Trust me.

    6. Migration Assistant: Yay! BUT FAST! PAY ATTENTION--did I mention I had to do this a few times?
    • A. WAIT until the program COMPLETELY calculates the sizes of all that is "you."
      B. You Want to Press Continue . . . I Know You Do! this would result in an incomplete transfer that would hang for . . . a f[CENSORED--Ed.]ing day. Force to restart the process and you get
      C. Duplicates of You that Cannot be Remov'd . . . unless . . . you . . . start all over again!
      D. Know Your Apple-ID and Password--your Set Up will want to do it. Also, the current iTunes is higher than the one--as of this writing--contained in the downloadable High Sierra, so your Set-Up will happily offer to download and update. So you better remember your WiFi Password!

    7. Good News: everything transfers. Did not even have to sign into places passwords were saved.

    Clones, Hybrid-SSD, High Sierra . . . and You:
    This final caution comes from . . . well . . . mess-ups. Having successfully done all of above, happy with everything, I recloned that drive. Neat! Back-ups are a good thing!

    I then did something stupid with a new version of a program . . . "fine, I'll just recover from the clone." Normally, I test new things on my clones, but see "stupid" mentioned previously.

    The recovery worked, but I lost 40GB of space on my 1TB Hybrid-SSD. [​IMG]

    Where did it go? I have no idea. Inspecting both the clone and my Hybrid-SSD I noticed that about EVERYTHING was larger. Each application was almost 1GB larger. Why? I do not know. Everything worked.

    So I had to start over again, use Migration Assistant, back to normal hours later.

    The caution maybe due to some combination of the following:

    • 1. Clone NOT APFS--yes . . . I should reformat it and all of that.
      2. As such, coming from a Non-APFS architecture to your APFS "something go wrong."
      3. Space Aliens

    --J.D.
     
  3. Doctor X

    Doctor X
    uix_expand uix_collapse
    Registered

    Joined:
    Nov 21, 2007
    Messages:
    1,572
    Likes Received:
    21
    Incidentally, having all done that above, App Store does detect the 10.13.1 and iTunes 12.7.1 updates.

    Will see if they work properly after cloning. . . . :eek:

    --J.D.
     
  4. Doctor X

    Doctor X
    uix_expand uix_collapse
    Registered

    Joined:
    Nov 21, 2007
    Messages:
    1,572
    Likes Received:
    21
    . . . and they are! [​IMG]

    --J.D.
     
  5. amcliz

    amcliz
    uix_expand uix_collapse
    Registered

    Joined:
    Mar 10, 2005
    Messages:
    61
    Likes Received:
    0
    I'm running 10.12.6 on my MacPro 12 Core (Mid 2010) with 64GB and 520GB SSD Drive plus QTY 3 x 3TB Internal HDD Drives.... plus 15TB DroboS Gen 2 (Firewire).

    I want to upgrade to High Sierra... all my core software has been updated to be compatible... anyone have any issues with upgrading an old MacPro 2010.

    Inhave a full backup on my Drobo of my entire system (520GB Boot Drive plus QTY 3 x 3TB Internal HDD Drives).... so I feel safe enough... but always nervous about upgrading, especially as my machine gets old and older. Should I be concerned about this APFS feature...?

    I upgrade my new MacPro 2017 with Touch Bar and had no issues at all.... but I have nothing important on that computer so I wasn't too worried if anything happened on there...but this is my main work machine... a very different story with this computer.

    Any comments or suggestions most welcome.
     
  6. Doctor X

    Doctor X
    uix_expand uix_collapse
    Registered

    Joined:
    Nov 21, 2007
    Messages:
    1,572
    Likes Received:
    21
    IF your computer is compatible with High Sierra follow the instructions I gave above. I prefer having an actual Installation Disk rather than trusting Al Gore's Interwebz. Further, while your SSD drive should be compatible, there may be a problem with your connected HDD drives. See my comments on Hybrids. Technically, non-SSDs are not supported "yet," which leads me to suspect you need to erase and formate ALL the drives as APFS. The linkypoo from oxdaily gives a suggested way to do this without APFS, but I have no experience with this.

    IF your computer is not compatible with High Sierra [​IMG], then the link from oxdaily I gave discusses the subject. HERE does not allow discussions of "Hackintosh" so I will leave it at that other than to note I did not try it.

    It seems the "problem" is that High Sierra really does not handle non-SSD at all well from an upgrade in place standpoint. As I pontificate, erase --> install --> Migration Assistant from your clone seems to not only work, it accepts future upgrades.

    Since you indicate that you have backed up your critical data and all of that, you can try what I recommended for Hybrid-SSD--just . . . be prepared to wait [​IMG]. It took ~6-8 hours for ~450GB of "me" to transfer. So if you have tetrabytes of "you" to transfer . . . well . . . see my recommendation to binge watch the Australian Rake above.

    --J. "F[CENSORED--Ed.]k Me Sideways!" D.
     
  7. pedz

    pedz
    uix_expand uix_collapse
    Registered

    Joined:
    Oct 13, 2002
    Messages:
    407
    Likes Received:
    0
    Two questions:

    1) How is the new file system as far as bug reports, etc?

    2) I've been told that it converts the native disk's file system but will it also convert my Time Machine disk? I'd prefer to use the older trusted file system for that until the new one proves trustworthy. What I'm basically asking is -- do I need to go buy a new Time Machine backup disk?
     
  8. Cheryl

    Cheryl
    uix_expand uix_collapse
    Rosie Moderator
    Staff Member Mod

    Joined:
    Dec 26, 2001
    Messages:
    4,408
    Likes Received:
    86
    Doctor X likes this.
  9. pedz

    pedz
    uix_expand uix_collapse
    Registered

    Joined:
    Oct 13, 2002
    Messages:
    407
    Likes Received:
    0
    Hmm... I have an SSD on my laptop. The laptop is a MBP new in Feb. 2017. And I have a Time Machine backup that I can disconnect when I start to do the update.

    I'm toying with the idea of doing a clean install... Another thought is to wait. I'm planning on getting some type of iMac when the iMac Pro comes out. Depending upon the pricing, etc will determine which one I'll get. I can move my "home" over to it and then do a clean install on the MBP and put what I need back on it. The MBP will be my travel mac. With the way that the "cloud" stuff works I'm going to two a two system method (again) -- a system at home and one for travel. I had this long ago but stopped because keeping multiple machines up to date and in sync was annoying. But now, it seems much easier.

    Thank you for your reply.
     
  10. Doctor X

    Doctor X
    uix_expand uix_collapse
    Registered

    Joined:
    Nov 21, 2007
    Messages:
    1,572
    Likes Received:
    21
    The only reason I "upgraded" was, at first, to try it since what I know about Apple which is they are not "going back." This is not Lion which you could ignore until they came up with a better OS. So the new architecture is the new architecture, and programs will eventually adapt to it.

    For you, who has an SSD, you should have no problem though exercise the usual "clone first/back-up/sacrifice a virgin" precautions.

    The question is "do you need" it. I would state that you do not need it now, since I do not need it, and if there is anything certain in the world over-rated Paul McCartney songs which we live in: it is all about me. I am unaware of any mainstream programs only compatible with High Sierra other than some updates: for example, the much lov'd Onyx has a version for High Sierra and you can still use their Sierra.

    Problems:
    The major "irritating" problem is that your Mac stops automatically recognizing Ex-HDs. Mine are encrypted so perhaps that is an issue. Mine are also LARGE and partitioned with one handling back-ups to my Int-HD and the other partition handling "stuff"--raw data like pictures, documents, highly artistic French harem anime . . . for research, of course, for a friend.

    I usually notice that if I hook up the Ex-HD either nothing happens or it only recognizes and asks for the password for one partition. I have to use Disk Utility to mount the partition or the whole Ex-HD. Granted, my Ex-HDs are not SSD, so that may be a problem.

    Other than that, Mrs. Lincoln, everything else seems to run fine as far as I can tell. So you probably are better off, if you do not need it, everything is fine, just waiting until Apple [PBUT--Ed.] sorts it all out.

    --J.D.
     
    #10 Doctor X, Nov 13, 2017
    Last edited: Nov 13, 2017
  11. Doctor X

    Doctor X
    uix_expand uix_collapse
    Registered

    Joined:
    Nov 21, 2007
    Messages:
    1,572
    Likes Received:
    21
    I will note that using App Store to direct download and update to 10.13.2 caused a problem. It may be because I did not wait long enough for the Mac to reboot--got impatient. This rendered the OS unable to update: if you restart, it would hang . . . for hours. Mac would still boot, but then you are still on 10.13.1 with App Store asking you to restart or maybe buy a newer Mac. . . .

    Recreated from a clone--see repeated warnings to do that above!--then downloaded the update and tried that. Worked fine. I was patient; however, the time period for the reboot was much shorter.

    --J.D.
     
  12. Doctor X

    Doctor X
    uix_expand uix_collapse
    Registered

    Joined:
    Nov 21, 2007
    Messages:
    1,572
    Likes Received:
    21
    ["Poof!"--Ed.]

    Unrelated mistake.

    --J.D.
     
    #12 Doctor X, Dec 7, 2017
    Last edited: Dec 7, 2017
  13. SGilbert

    SGilbert
    uix_expand uix_collapse
    Registered

    Joined:
    Sep 11, 2005
    Messages:
    994
    Likes Received:
    23
    Ever since the supplemental 10.13.2 update, I (and my wife's) MBP's have a long lag before anything shows up on the desktop.
    Screen shots, App downloads, dmg opening, etc. Anything going to the desktop.
    Anywhere from 15 seconds to almost a minute.
    Emptying the trash takes forever too.
    Totally frustrating and unacceptable!!
    Anyone else experiencing the same?
    Hopefully, 10.13.3, due soon, will correct this.

    Edit: 10.13.3, out 1/23/18, did NOT fix this.
     
    #13 SGilbert, Jan 22, 2018 at 12:15 PM
    Last edited: Jan 23, 2018 at 1:17 PM

Share This Page