Oh, my trash


It seems that my user does not have access to delete something from the trash because I don't have enough permission. I'm very confused on how I would go around deleting my Trash. It seems that I have downloaded/cp'ed something to my user from root and placed it in the trash from the OSX gui. Can i delete my trash through a terminal logged in as root? Anyone had a similar problem?
I too ended up with things in the trash that even as root I could not delete.

The solution was to drag them from the trash and put them on the OS 9 desktop. Restart in OS 9 and delete them from there!

...a tip that I got from here!

Have you tried to dragging them out of the trash to a new folder and then just using the 'del *' in a console from root? Its really a hasle, apple should do something about it
Will try next time if/when it happens...I have only had it once...you seem to have it more often....when does it happen for you?
Isn't 'del *' a DOS command? The unix command for deleting files is 'rm' but I'm not sure how to delete files in batch. I had the same problem with my trash, so I just used RBrowser as root (sudo open /applications/RBrowser), navigated into my trash (~/.trash), selected everthing in the folder and deleted it from there. Worked like a charm. The only problem is if you have locked files.... You will have to unlock each of them, one by one unless you boot into OS 9 hold opt while emptying the trash.
Oh yes, that is what i ment :X rm -rf *
(too much winblows for me) thanks for the tip.
have you tried fink? i would like to get gnome-core to compile but it doesn't using fink, anyone know the problem?

BTW: Fink is a great app, it downloads packages for you and compiles them. Kind of like the ports tree for BSD. You should try it, i got enlightenment working perfectly with gimp...but not gnome, anyone know why?