old iMac DV will not power up


I've read thru past posts and haven't found anything, so, here it goes. . .

About a year ago, I took my old imac out of the closet and gave it to my mom. It's been working fine for her until the past two days. It will not power up. She has checked all cables. Tried other power outlets. Tried powering of both keyboard and monitor. If recall, years ago there were some problems with stuck power buttons, but she says she can hear the buttons click and feel them depress.

What can I have her try?

The specs, from what I recall: imac DV SE, 400 MHz, 512MB RAM, was running OS 9.

Thank you for reading and any assistance you can offer.
Welcome to the forum.

Did mom install anything? {probably not, but I had to ask :) }

Have her try resetting the PRAM .

Start up the computer and immediately hold down the option + apple + p + r.
Have her continue to hold down those keys until she hears the start up chimes three times. Then release the keys and see if it starts up.

How long was it sitting in the closet? Did she notice if the date and time was off the last time she started up?
Does anything happen at all when the power button is pressed? Any clicking or whirring, like from the hard disk?

I had a power problem with my old iMac DV, which was from the same generation as yours. But mine at least made it to the startup chime before it conked out. In any case, it could be a bad power supply, but it's hard to say.

Before the problem occurred, how heavily was the computer used? When the problem started with my iMac, it was after it had been on constantly for several months, and hardly ever even asleep during that time. If yours had been shut down normally, then I think a power supply problem is less likely.
I replaced the PRAM battery when I gave it to her. I can't imagine it dead already.

The only sound that comes from it is the click of the power button. I know she had a tendency to leave the computer on all day, but she did shut down at least every night. Is there a way to test the power supply, or do I just have to change it and see if it works?