One more thing....browsing the xserve from a pc

babaton

Registered
ok, smb services are setup ok, I can connect via smb from macs and pcs, no problem.I'm logging in as an active directory user,the server is bound to the AD.

But, If I try to browse the xserve from the Pcs network neighbourhood I get told I don't have permission and I can't even look at the shares available on the xserve.

So I tap in the ip address : \\192.168.0.1 and it connects fine without asking for authentication since i'm already logged into the AD.

Then I try \\xserve and I'm told I don't have permission.

So it looks like its a name resolution problem, except when i do an nslookup on the pc I can resolve the name.

stumped.....
 

Go3iverson

Registered
Be sure that all of your Windows DNS servers have the proper forward and reverse DNS entries. I've seen Windows get a little lazy about replicating at times. Try using the host command from an OS X machine. You can use host with specified DNS servers and you can host hostname or host IP_Address to resolve both forward and reverse pointers.

On your server, did you manually assign a static IP, or did you create a DHCP reservation and then allow your Xserve to run off DHCP? I've found that Windows won't actually create proper DNS entries for machines with hard assigned IPs, at least in my environments. If you create the DHCP reservatoin and then allow the Xserve to 'request' an IP, it will register in DNS as well.

When all else fails, reboot the server and give it another chance to hit your DNS. :)
 

lurk

Mitä?
Have you set the server to allow browsing? As a general rule it is good security practice to disable browsing since it prevents people searching for open or misconfigured shares. If you are supposed to be there you already know the link anyway is the idea. Assuming that the xserve is defaulting to the most secure configuration I expect it would not allow browsing.

So to make things browsable you need to turn it on, I don't know how to do that using the Apple tools but it is a cinch to do with swat or by editing the config files.
 
Top