OS X causing strange RAM problems in OS 9

flaming_pig_boy

Registered
Here is one for the story books:

OS X.1 seems to work fine. However, when I run programs from OS X in Classic, it seems to befuddle the functionality of the program. Let me explain:

I ran Photoshop 6 from OS X in Classic. It worked well. I have to boot into OS 9 to use my smartMedia drive, and so while I was there I thought I might use photoshop a little. Photoshop will no longer allow me to save or open anything. I can double-click files and they open fine. If I choose "File:Open" i get an error that there is not enough memory. Same with trying to save. Now for the longest time I thought this was a problem solely belonging to Photoshop. But, it wasn't.

I also ran Shrinkwrap. Shrinkwrap gives the same error when i choose "Mount disk image..." Telling me I don't have enough RAM. Appleworks and Acrobat (which are both carbon programs, which i find a little odd) don't give an error, rather they just ignore my request. I choose "File:Open" and nothing happens.

is it just me, or is this a little on the odd side of things?

I tried reinstalling photoshop 6. Same error. I deleted the preferences. No good. I turned virtual memory ON hoping maybe it would trigger something. No good. I booted with extensions off. no good.

so here is the question: how does opening an application and using it is OS X make it not work in classic. There must be something..Somewhere..doing something, but I don't know what it is. For instance, I have never used Illustrator in OS X and it still works fine. So does everything else. It is just those applications (Classic only OR carbon) that I used in OS X.

If reinstalling does no good, and booting without extensions does no good, then there must be some internal remnant of OS 9 that is retaining information about applications that were used while OS 9 was functioning as "Classic". Now would be a good time to do that 2 system folder thing I guess. Or maybe it would've been good to do it awhile ago.

Let me now add an ubiquitous face :confused:

if anyone has any suggestions, I think I might like to hear them. if the suggestion is merely "reinstall OS 9" then don't bother. I am seeking more an understanding of this than a solution. Maybe to gain this understanding I have to reinstall OS 9. but..yes..the question will plague me: Why?

thanks

Seth
 

Pauldunlop

Paul Dunlop
Damn man. Interesting one ! I really struggle to think what could be causing this. OS X does leave remnance in OS 9.....quite a lot actually. Which makes it such a pig to reinstall without reformatting.

Anyhow, the only things that come to mind straigh away are going to be far to obvious. You seem like you know what you're talking about, so I'd guess you've checked this, but have the apps actually got enough RAM assigned to them in OS 9......try giving them some more while you're at it.

Now, I really doubt that that will solve the problem. But the weird thing is, as I type this, I do remember having a similar problem before......infact, it was exactly like you're describing it. And I think I had OS X installed too. Hmmmmm.......now what the hell did I do about it ? LOL

:confused:

Hmmmm, and if I remember right, I tried the reinstalling too, but the problem just came back, not straight away, but within an hour. The only things I can think of right now would check the memory, delete all preferences you can find relating to the apps, including any hidden ones you might know of, and maybe try installing it somewhere else on your drive. Might sort it.

As for understanding what causes it, I really don't think its to do with OS X's classic environment, despite how it might seem. It simply shouldn't be the case, because of the way Classic works. OS X leave crap all over OS 9 after the first run of classic, but it shouldn't dump anything else after that. I think its actually going to be an OS 9 problem. Now the likelyhood is that, if the apps work in Classic, but not OS 9, is that its going to be a problem with a system component, one that doesn't usually function in classic.

That'll let you narrow down the search for the problem. It could definitely be a problem with virtual memory.....could very very likely be a cause. I know you didn't want to here this, but try reinstalling OS 9.....that's probably the only way to do it. Alternatively, try deleting the VM files that OS 9 uses. Quite easy to get at with something like ResEdit, or anything that lets you see and edit invisible files. Delete em, replace the Memory extensions and control panels, as well as delete the memory preferences, anything relating to memory, RAM, and Virtual Memory.

See if that works. And please, let me know. Very interesting problem.
 

flaming_pig_boy

Registered
(yes, photoshop has plenty of RAM allocated)

BUT..I think I may have figured more stuff out. Here is a list of applications I found to be affected by this problem:

Photoshop 6
Internet Explorer 5
iTunes
SoundJam
Appleworks
Shrinkwrap
Acrobat 5
iMovie

Now, here is a list of a few applications that were not affected:

Photoshop 5.5
Illustrator 8
AudioCatalyst
ResEdit
Bryce 4
SoundEdit 16

So here is what I propose: With little exception the programs that don't work are NEW. The ones that still work are OLD. I think you are right about the fact that it is an OS 9 problem rather than an OS X problem.

Another interesting note is that applications like Photoshop don't even work in OS X right anymore. Of course they will launch, they just don't accept the "File:Open" command. Carbon (i think that's what they're called, the programs that run in OS 9 and OS X) programs like Appleworks and Acrobat 5 work fine in OS X. Only because they aren't using the hell-struck OS 9.

So I wonder..Could it perhaps be something like the CarbonLib? I noticed that OS X replaced my CarbonLib on november 2nd with a new one. But it doesn't seem to me that programs like Photoshop use the carbonLib. Unless..They don't..Except when a person tries to open or save..or..something (a weak conclusion I guess).

and--ohmygod! I have to go to work. (deserving of: :mad: )

Thoughts?

Seth
 

flaming_pig_boy

Registered
yeah, okay. i was right about it. CarbonLib doesn't seem to have anything to do with it.

When I turned Virtual Memory ON it didn't do anything either, so I turned it back OFF.

I had tried disabling the whole package "Classic Compatibility" before to no avail, but in despair I tried again. Still no good.

There is something that to OS X 10.1 update installed in OS 9 that is causing this. I think that is a safe conclusion. Now, if only we could figure out what.
(looks like I might be reinstalling after all)

Seth
 
Top