Os X Printing Thru Netgear Router

PtotheP

Registered
I'm networking one G4 with OS X together with a Dell sporting Win XP SV2. A lovely Netgear wireless router joins them both. The G4 will recognize the Dell (can see/access the ShareDocs file) and can surf the web fine using the DSL connection that the router is managing; however, I can't get it to work with the Netgear built-in print server.

Under Add New Printer, I've tried selecting IP printing with LPR/LPD, typing in the IP address of the router, and selecting my HP 1200. It keeps giving me a "server-error-service-unavailable" message. (Pinging the IP address always works, as evidenced by the Internet connection that works fine.) Earlier I managed to send an iBook's contents thru the router to the printer in this fashion, so I'm pretty sure the steps are correct.

Can anyone help troubleshoot?
 

gsahli

Guest
With Jaguar and Panther, you have to also enter the device-specific Queue Name when you ADD the printer in Printer Setup/Center. This is usually found in the print server (router) Docs in the unix/linux instructions. I think it is L1 for your Netgear.

(Tiger is better at auto-detecting the queue name, but sometimes faulters, too)
(& I'm sure by now you've figured out there is no separate IP address for your printer)
 

PtotheP

Registered
I've tried adding L1 as well as the router name (what my Win XP config uses) in the Queue, to no avail. Any other ideas on why OS X won't connect to my HP LJet 1200 via the print server in the Netgear router?
 

glen

Registered
Hi There!
Sorry to have mislead you. My two printers are GCC and Epson. All I did was set their IP addresses then use them in the LPR dialog boxes. I guess HP doesn't work the same. From what I have been reading in the forums I guess I will stick with these two brands.
Glen
 

gsahli

Guest
What model router is it (so I can look up the queue name for you)?
BTW, Queue Name is sometimes called port name.
 

PtotheP

Registered
The router is a Netgear Model #FWP114P, and when I used a queue name to set it up in Win XP, it used the model name. The machine doesn't seem to want to auto-detect the name or set up a generic printer. Message is always the same: "server-error-service-unavailable."
 

gsahli

Guest
It appears that Netgear doesn't want Mac/Linux users to try to use the print server - I don't find any info from Netgear. After browsing for linux-related info, I find three possibilities for queue name: L1, P1 or the router model number.

Back to your error "service unavailable." Sorry I didn't address that before. I recommend you try Printer Setup Repair from www.fixamac.net. Do this before trying to ADD printers.

Good luck.
 
Top