OS X Upgrade Problem


Last night I upgraded my OS 9.2 to OS X. Now my system loads OS X, but I am unable to use the System Preferences or any other applications. I also get the message that my home directory can't be found.

After installing OS X, I noticed that I was never taken through a setup wizard for OS X.

Any suggestions? Is this a permissions problem?

Thank you in advance for you assistance.

P.S. I did all of my firmware and OS 9.2 upgrades before installing OS X.


mach-o mach-o man
I think I know exactly what that is.

What username did you use?

I used 'root' origionally, and it screwed everything up.

so of thats the case, re-install your Mac OS X. (just boot from the cd, and don't wipe the drive).

Hope this helps, and don't hesatate to ask additional questions.


I upgraded my system to OS X not X.1

I did try to reinstall OS X, but that did not help the problem. I even tried to create another user account, but each time I tried to access system preferences I was never able to get into that menu.

I did get a login screen somehow, but when I tried to login under my login created in system 9.2 the screen flickered but nothing happened.


First things first just FYI you can't upgrade from 9.2.1 to any version of 10. You do a full install. It just adds 10 with 9. So you cannot use any 9.2.1 and earlier passwords or etc in 10. 10 is completely independent except for the fact it uses 9.2.1 or 9.1 as Classic. So did you get an installer (wizard/setup) the second time you tried to install? You can always insert your OS X or 9 install disc to select a system to start up from. You will be asked to create an account, and insert other necessary information when you attempt to install any version of 10 unless you are upgrading from 10.x to 10.x. NowI would say if you can insert a CD to start up in your OS 9.2.1 and back-up anything you feel you should. And format and clean install both OS's. If you like you can also partition the drive. But we should be able to figure this out without you reformating your drive. Tell us more!



First of all, thank you for all of your help.

I did get an install wizard both times I installed 10.X. The install for 10.X went without a hitch, but when I actually booted up in 10.X the problems began.

Last night I started using my 9.1 disk and was able to access files from my 9.2.1 upgrade - so now all of my data is backed up. However, when I try to startup on the OSX cd I keep getting the install wizard. When I tried to quit the install wizard I was informed that the machine would restart itself if I did.

Yes, I know I can probably reformat and reinstall - but where's the challenge in that!!?!?!

Thanks again.