OS X will install but not boot!!!


I have been planning to put OS X on my machine for months. Accordingly, I bought a larger HD for my rev. D iMac and partitioned into two HFS+ partitions (7.73 GB and 1.3 GB) and two UFS partitions (11.77 GB and 10 GB and don't ask me whyI chose UFS). I got my OS X CD and ran the installer. It recognized the UFS volumes and I selected the 11.77 GB partition and chose the option to reformat to HFS+. It ran and installed and then restarted. It did not boot to OS X, however. I got a weird folder with a question mark followed by one with a Mac OS logo. It then booted to OS 9.

I installed OS X on both formerly UFS partitions and the 1.3 GB HFS+ and got nothing, even a blank grey screen and NO boot with the 1.3 GB partition. The two for OS X were reformatted in HFS+, Norton Util 6.0b confirmed that but the OS 9 Finder does not mount them.

My firmware is up to date, my PRAM has been zapped, and my desktop rebuilt to no avail. I plan on backing up my HD and then running Norton on the OS X drives. It says it has to reload the drivers or something and that if the partition is corrupt, it may crash. If that fails, I will reinitialze the disk and repartition, this time with 4 HFS+ and two boot partitions under 8 GB (I heard the firmware can't boot to anything over 8, although I don't know how that works since all new HD's are over 8 GB).

Well, to conclude this long post, I am open to help or suggestions. Feel free to post or email me with ideas. I really want OS X to work on my machine.
If you can boot into OS X try running the SYSTEM DISK utility that comes in your OS X CD. Select your OS X partition and then reboot.

You need to do this each time you boot into OS 9 and you want to go back to OS X.
That was the first thing I tried. The System Disk would not recognize either OS X disk, let alone allow me to boot off them.

I heard that OS X needs to be on the first partition with older machines. I am going to reformat this weekend and give that a try. Does anyone know if the first partition (the boot partition), needs to be under 8 GB with a rev D?
hey Timmy, i have the same problem on my imac 333 rev. D also - the cd was at first unreadable by this macintosh, so i went and copied it onto a Gold cd-r and Bingo! worked straight away.... Well, kinda worked :( i can't fully install it.. sux.
i have tried partioning my drive several times now, to no avail...Although i do not think i have tried to make the X destination on the first partition...
I'll re-initialise tomorrow and try that,,,,
Anything else one can try? -i have also tried what Timmy did, and that is selecting the system disk in the utilities in osx cd.. but that no w0rk either, the only option was my partition that had 9.04 onit-and it wouldn't do it.. just boots into 9, and stays there... other times i still get this cd is unreadable by this mac etc..

imac 333 rev. d , 160 ram.
<supposedly this imac model is ok to run osx pb, and i even went to the trouble of taking the cd into MacsPlace (a mac shop) and asking them to test it on an imac like mine, which they did, and it installed fine...and also on a cube>
I would not want to appear to repeat myself, but a great deal of these problems have been solved by formatting the drives using the Apple drivers...

Maybe is it the case here too ?
Pascal, what do you mean? CAN u format using something other than apples provided Drive setup?
please explain.

Maybe I wasn't right (based on your reaction), but a lot of people having problems installing and restarting into OS X can trace back their problem to a reformating of their drive using a third party formatter such as FWB HDTK (nobody seems to have had problems with Silverlining, though).

Indeed, one is not limited to using drive setup from Apple. There are many (3 ?) third party formaters on the market.

I am really dumfounded to see the number of people who seem, judging from the description of their system, to have a run-off-the-mill Mac that refuses to install OS X. I'm really looking forward to see the solution to this mystery !
Hey..... 200 tries later, and it finally installed properly :)
I don't think i did anything different from the previous 199 attempts either! - So i dunno why,.....
Anyway, it finally works for me.,.. hope others have success too
In my '99 Powerbook G3 Bronze keyboard, which has the same design for the processor card and memory configuration X wouldn't install. When I removed all but the stock 64MB of RAM, it installed perfect the first time, and booted and hasn't crashed since. So remove any non - Stock RAM. Good luck