OS X won't boot after running OS 9 (unsupported)


Before I begin, I'm running OS X PB on an non-upgraded 9600/300 using a new mach_kernel for 604e.

That said, I have successfully installed OS X on a 4GB internal SCSI drive (Bus 0, ID 2), and it ran fine. However, I've encountered severe problems after booting back into MacOS 9. From a cold start OS X started booting but after about 30 seconds of disk activity, it hung at the smiley face and swirling color pointer. After restarting twice it eventually never even made it back to that screen, but just defaulted back into MacOS 9 where I was met by a "This drive is unreadable, do you want to format" dialog. My OS X partition (HFS+) shows up unmounted in Drive Setup and not at all in System Disk, but does show up in the listing when I boot holding the Option key.

Here's what I've tried to no avail: zapped PRAM, rebuilt desktop (on OS9) drive, tried to mount in Drive Setup.

Has anyone else encountered this (supported or not)?

Also posted this at macnn:


Thanks for any help

[Edited by mcgritch on 12-02-2000 at 09:47 AM]